Bug 186937 - pop-before-smtp is out of date and broken with IPv6 (and newer Dovecot)
pop-before-smtp is out of date and broken with IPv6 (and newer Dovecot)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pop-before-smtp (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
http://sourceforge.net/mailarchive/fo...
:
Depends On:
Blocks: 171491
  Show dependency treegraph
 
Reported: 2006-03-27 11:02 EST by Michael H. Warfield
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.41-1.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-25 12:09:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael H. Warfield 2006-03-27 11:02:10 EST
Description of problem:

When IPv6 is enabled (which it is by default) Dovecot logs IPv4 addresses into
the maillog log file in the compatibility format ::ffff:{IPv4}.  This format is
not recognzied by the pop-before-smtp regex in version 1.36.  This was fixed in
version 1.37.  The current version for pop-before-smtp is 1.41 and the 1.36
version is over a year and a half old.  This package is really out of date and
needs to be brought up to the current version.  This old version would not even
recognize the newer Dovecot logging format of "rip=" so is probably broken even
when IPv6 is not enabled (not tested).

Note discussion in thread at URL where they were hoping to, at least, see 1.39
in FC5.  This is broken in FC4 and FC5.


Version-Release number of selected component (if applicable):

1.36

How reproducible:

Always fails

Steps to Reproduce:
1. Enable pop-before-smtp for Dovecot and test
2. Addresses are not added to popauth database
3. Addresses in log file are in ::ffff:{IPv4} format and not recognized
  
Actual results:

No addresses are added to the popauth database

Expected results:

Each authenticated address should be added.


Additional info:

Package is terribly out of date and broken.  Needs to be brought up to date to
match current log formats and IPv6 support.
Comment 1 Warren Togami 2006-04-19 20:30:12 EDT
You generally need to modify it to use your log format anyway.  If you want it
to support ipv6 out of the box, then pleaes submit suitable patches that are
accepted upstream.  When upstream has it, I will incorporate it here.
Comment 2 Michael H. Warfield 2006-04-20 23:04:43 EDT
Excuse me?

The current release upstream already incorporates the relevant patches and has
for some time.  They don't need any more patches.  All that's needed is to
update Fedore Extras to the 1.41 release and incorporate the fixes that already
exist upstream.  1.41 already supports IPv6 compatibility addresses out of the
box.  Fedora extras doesn't because it's only 1.36 (and I've checked the regex's
and they are NOT backported patched).

You say, "When upstream has it"...  Well...  Upstream has had it for over a
year.  Looking forward to Fedora Extras picking it up.


Comment 3 Warren Togami 2006-05-25 12:09:19 EDT
1.41-1.fc5 has been in Extras for a while now.

Note You need to log in before you can comment on or make changes to this bug.