Bug 1869633 - A change VM's boot order while it's running shows a change in disks/NICs
Summary: A change VM's boot order while it's running shows a change in disks/NICs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Ido Rosenzwig
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-18 11:57 UTC by Ido Rosenzwig
Modified: 2020-10-27 16:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:29:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6354 0 None closed Bug 1869633: Show only boot-order at pending changes warning on boot order change 2020-09-29 05:48:09 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:29:38 UTC

Description Ido Rosenzwig 2020-08-18 11:57:51 UTC
Description of problem:
When changing the boot order while the VM is running the alert at the top of the page shows a change in the disk/nic although no change has been made in the disk/nic properties.

When looking at the VM's YAML the boot order is indeed part of the device attributes but in the web UI when trying to add or modify a device there is no boot-order property. Thus, from a user perspective there it is a bit confusing.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. create a VM (via YAML page)
2. change the boot order in the Details page - add a nic and move it to the top
3.

Actual results:
boot order is shown in the warning at the top of the page as well as the network interfaces and disks

Expected results:
only boot order needs to be shown

Additional info:

Comment 4 errata-xmlrpc 2020-10-27 16:29:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.