Bug 186966 - History (and "history") not working on new octave-2.1.73
History (and "history") not working on new octave-2.1.73
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: octave-forge (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Quentin Spencer
Fedora Extras Quality Assurance
:
Depends On: 186964
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-27 14:10 EST by Piergiorgio Sartor
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-27 16:43:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piergiorgio Sartor 2006-03-27 14:10:58 EST
Description of problem:
After launching the new octave, from terminal, the history
seems not to be "enabled", i.e. there is no history.

Version-Release number of selected component (if applicable):
2.1.73-1

How reproducible:
At the moment, it seems very often, but somehow
not always, once it happen the history was updated
(don't know if something special happened).

Steps to Reproduce:
1.
Upgrade from 2.1.72-3 to 2.1.73-1 (maybe important).
2.
Start "octave".
3.
Type some commands, like "ls", "plot(1:10)"...
4.
History back, with arrow-up or "history" command.

Actual results:
The new commands are not browsed, only the one from the previous
session (eventually from 2.1.72) are available and "history"
does not return, of course, nothing new.

Expected results:
The immediate history should be browsable and available.

Additional info:
More funny is the following, if the ~/.octave_hist file is empty
(> ~/.octave_hist), or not present (rm ~/.octave_hist), the "history"
command produces a nice segmentation fault.
In 2.1.72 this was not happening, since "history" returned:

  1 history

So, the history is always not empty.
Comment 1 Quentin Spencer 2006-03-27 16:43:25 EST
I was partially able to duplicate this. I am still not sure what was causing it,
but the problem appears to be somehow related to the incompatibility of
octave-2.1.73-1 and octave-forge-2006.03.17-1 (see bug 186966). Only with both
of these installed simulaneously could I duplicate the problem of not seeing
past commands with the up arrow. Removing octave-forge, or installing a
recompiled version of octave-forge seemed to make the problem go away. I was not
able to create a core dump.

I am marking this as an octave-forge bug, dependent on 186966, and I am closing
it assuming that the forthcoming release of octave-forge-2006.03.17-2 will make
the problem go away.

Note You need to log in before you can comment on or make changes to this bug.