Bug 1869780 - [scheduler] - Version is injected incorrectly for OPERAND_IMAGE_VERSION
Summary: [scheduler] - Version is injected incorrectly for OPERAND_IMAGE_VERSION
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-scheduler
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Jan Chaloupka
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-18 15:46 UTC by RamaKasturi
Modified: 2020-10-27 16:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:29:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:29:38 UTC

Description RamaKasturi 2020-08-18 15:46:51 UTC
Description of problem:
When oc get co kube-scheduler -o yaml i see that kube-scheduler version to be 1.18.3 where as it is supposed to be 1.19

versions:
  - name: raw-internal
    version: 4.6.0-0.nightly-2020-08-18-015339
  - name: kube-scheduler
    version: 1.18.3
  - name: operator
    version: 4.6.0-0.nightly-2020-08-18-015339

 - name: OPERATOR_IMAGE
          value: registry.svc.ci.openshift.org/ocp/4.6-2020-08-17-023817@sha256:7d213cb820522d4b3bac095a5e8e86cdd40b3e49eb91c09c6060f505d8c99faf
        - name: OPERATOR_IMAGE_VERSION
          value: 4.6.0-0.ci-2020-08-17-023817
        - name: OPERAND_IMAGE_VERSION
          value: 1.18.3
        - name: POD_NAME
          valueFrom:
            fieldRef:
              apiVersion: v1
              fieldPath: metadata.name

Version-Release number of selected component (if applicable):
[ramakasturinarra@dhcp35-60 ~]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-08-18-015339   True        False         9h      Cluster version is 4.6.0-0.nightly-2020-08-18-015339


How reproducible:
Always

Steps to Reproduce:
1. Install 4.6 cluster
2. Run oc get co/kube-scheduler -o yaml
3.

Actual results:
versions:
  - name: raw-internal
    version: 4.6.0-0.nightly-2020-08-18-015339
  - name: kube-scheduler
    version: 1.18.3
  - name: operator
    version: 4.6.0-0.nightly-2020-08-18-015339

Expected results:
version should be 1.19

Additional info:
kube-scheduler logs says the version is Starting Kubernetes Scheduler version v1.19.0-rc.2.455+99cb93adf04c3e-dirty

Comment 2 Jan Chaloupka 2020-09-01 14:29:34 UTC
Checking `oc get co kube-scheduler -o yaml` again:

```
  versions:
  - name: raw-internal
    version: 4.6.0-0.ci-2020-08-31-045252
  - name: kube-scheduler
    version: 1.19.0-rc.2
  - name: operator
    version: 4.6.0-0.ci-2020-08-31-045252
```

From `oc get pod -n openshift-kube-scheduler-operator -o yaml`:

```
      env:
      - name: IMAGE
        value: registry.svc.ci.openshift.org/ocp/4.6-2020-08-31-045252@sha256:7b2e7030337800dcacf7464a889544b2277c96f2bd5a12975515882f59837ebb
      - name: OPERATOR_IMAGE
        value: registry.svc.ci.openshift.org/ocp/4.6-2020-08-31-045252@sha256:3c22479a01f019280f2814cf0c15211ef1ec873c2d050f3a13b158eb2f00d3ac
      - name: OPERATOR_IMAGE_VERSION
        value: 4.6.0-0.ci-2020-08-31-045252
      - name: OPERAND_IMAGE_VERSION
        value: 1.19.0-rc.2
```

Comment 3 Jan Chaloupka 2020-09-01 14:30:01 UTC
Please reopen if the issue still persists

Comment 4 RamaKasturi 2020-09-01 15:29:04 UTC
@jan, could you please help me understand why this is closed as not a bug ?

Comment 5 RamaKasturi 2020-09-02 12:12:07 UTC
Moving this to verified as i see that the bug is fixed.

[ramakasturinarra@dhcp35-60 openshift-apiserver]$ oc get co kube-scheduler -o yaml
 versions:
  - name: raw-internal
    version: 4.6.0-0.nightly-2020-09-01-070508
  - name: kube-scheduler
    version: 1.19.0-rc.2
  - name: operator
    version: 4.6.0-0.nightly-2020-09-01-070508

[ramakasturinarra@dhcp35-60 openshift-apiserver]$ oc get pod -n openshift-kube-scheduler-operator -o yaml

 env:
      - name: IMAGE
        value: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:48e2f3f64f28be7c89c278cc2b65d9efab682f5db691e6920f7be82e3ee0183d
      - name: OPERATOR_IMAGE
        value: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:1dec0ef12a240e4af6da4c5caa678657841162617dd66719e7b7b0d131982ec2
      - name: OPERATOR_IMAGE_VERSION
        value: 4.6.0-0.nightly-2020-09-01-070508
      - name: OPERAND_IMAGE_VERSION
        value: 1.19.0-rc.2

Comment 6 RamaKasturi 2020-09-02 12:12:57 UTC
Payload in which the fix was verified.

[ramakasturinarra@dhcp35-60 openshift-apiserver]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-09-01-070508   True        False         5h16m   Cluster version is 4.6.0-0.nightly-2020-09-01-070508

Comment 9 errata-xmlrpc 2020-10-27 16:29:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.