Bug 186999 - F-spot crashes on startup with unhandled DBus exception
F-spot crashes on startup with unhandled DBus exception
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: f-spot (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-27 16:48 EST by Charles Simpson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-27 17:31:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Simpson 2006-03-27 16:48:12 EST
Description of problem:
F-spot crashes on startup with unhandled DBus exception

Version-Release number of selected component (if applicable):
0.1.10

How reproducible:
Always.  F-spot worked once, imported some photos.  After closing F-spot, it
crashes each time I try to re-open it.

Steps to Reproduce:
1. Start F-spot
2. Import photos
3. Close F-spot
4. Reopen F-spot (even with imported photos removed)
  
Actual results:
F-spot crashes

Expected results:
F-spot opens

Additional info:
If starting from the command line, I get the following messages:

Found active FSpot server: FSpot.Core.Proxy

Unhandled Exception: DBus.DBusException: No reply within specified time
in <0x0011c> DBus.Message:SendWithReplyAndBlock ()
in <0x00062> FSpot.Core.Proxy:Organize ()
in <0x004d8> FSpot.Driver:Main (System.String[] args)

I've tried with the camera plugged in and unplugged, tried deleting the
previously imported photos.
Comment 1 Charles Simpson 2006-03-27 17:31:21 EST
Problem could probably be closed.  Reboot fixes problem, but does not explain
why the problem occured to begin with.

Note You need to log in before you can comment on or make changes to this bug.