Bug 1870074 - [sriov]pfname 'ens3' also be config when creating sriovnetworknodepolicy and pfname is 'ens3f0'
Summary: [sriov]pfname 'ens3' also be config when creating sriovnetworknodepolicy and ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: zenghui.shi
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-19 10:12 UTC by zhaozhanqi
Modified: 2020-10-27 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:29:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift sriov-network-device-plugin pull 28 0 None closed Bug 1870074: pfName selector: match exact pf name (#263) 2020-12-20 16:03:10 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:29:25 UTC

Description zhaozhanqi 2020-08-19 10:12:29 UTC
Description of problem:
There are two node: 

node1 have pf 'ens3f0' and node2 have pf 'ens3' 
and the other are same (pciaddress and vendor)

node1:

    deviceID: "1017"
    driver: mlx5_core
    linkSpeed: 40000 Mb/s
    linkType: ETH
    mac: 98:03:9b:97:36:c6
    mtu: 1500
    name: ens3f0
    numVfs: 2
    pciAddress: 0000:5e:00.0
    totalvfs: 2
    vendor: 15b3

node2:

    deviceID: 101b
    driver: mlx5_core
    linkSpeed: -1 Mb/s
    linkType: ETH
    mac: 0c:42:a1:6b:2a:e0
    mtu: 1500
    name: ens3
    numVfs: 1
    pciAddress: 0000:5e:00.0
    totalvfs: 1
    vendor: 15b3

when creating the following policy with 'pfname' is ens3f0
*****************
apiVersion: sriovnetwork.openshift.io/v1
kind: SriovNetworkNodePolicy
metadata:
  name: mlx278-netdevice
  namespace: openshift-sriov-network-operator
spec:
  mtu: 1500
  nicSelector:
    pfNames:
      - ens3f0
    rootDevices:
      - '0000:5e:00.0'
    vendor: '15b3'
  nodeSelector:
    feature.node.kubernetes.io/sriov-capable: 'true'
  numVfs: 2
  resourceName: mlx278netdevice

***********

found the the other node wih pfname is ens3 also be config. 

Version-Release number of selected component (if applicable):

4.6.0-202008121454.p0

How reproducible:
always

Steps to Reproduce:
1. there are 2 nodes and each node have one Mellanox
2. Check the nodestate for those two node
3. Create the policy in description 
4. Check those two nodes info 

Actual results:

oc get node node1 -o yaml | grep "openshift.io/mlx278netdevice"
          f:openshift.io/mlx278netdevice: {}
          f:openshift.io/mlx278netdevice: {}
    openshift.io/mlx278netdevice: "2"
    openshift.io/mlx278netdevice: "2"

oc get node node2 -o yaml | grep "openshift.io/mlx278netdevice"
          f:openshift.io/mlx278netdevice: {}
          f:openshift.io/mlx278netdevice: {}
    openshift.io/mlx278netdevice: "1"
    openshift.io/mlx278netdevice: "1"

Expected results:

node2 should not be set openshift.io/mlx278netdevice
oc get node node2 -o yaml | grep "openshift.io/mlx278netdevice"
        
Additional info:

Comment 5 zhaozhanqi 2020-08-28 05:22:07 UTC
Verified this bug on 4.6.0-202008261930.p0

Comment 7 errata-xmlrpc 2020-10-27 16:29:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.