Bug 1870082 - OpenStack IPI install fails when given availability zone name has uppercase letters
Summary: OpenStack IPI install fails when given availability zone name has uppercase l...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Pierre Prinetti
QA Contact: David Sanz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-19 10:29 UTC by Pierre Prinetti
Modified: 2020-10-27 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:29:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer issues 4069 0 None closed OpenStack IPI install fails during bootstrap due to availability zone name 2020-09-18 11:15:50 UTC
Github openshift installer pull 4070 0 None closed Bug 1870082: Use index in MachineSet names for Openstack IPI 2020-09-18 11:15:51 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:29:25 UTC

Description Pierre Prinetti 2020-08-19 10:29:43 UTC
Description of problem:

Bootkube process loops endlessly to create the worker machineset due to the availability zone name having uppercase letters.

How reproducible: 100%

Steps to Reproduce:

1. Use availability zone name in install-config having at least one capital letter.
2. Run the create cluster command.


Actual results:
```
Aug 19 09:57:13 yus-pt67t-bootstrap bootkube.sh[2565]: [#12247] failed to create some manifests:
Aug 19 09:57:13 yus-pt67t-bootstrap bootkube.sh[2565]: "99_openshift-cluster-api_worker-machineset-0.yaml": failed to create machinesets.v1beta1.machine.openshift.io/yus-pt67t-worker-PowerKVM -n openshift-machine-api: MachineSet.machine.openshift.io "yus-pt67t-worker-PowerKVM" is invalid: metadata.name: Invalid value: "yus-pt67t-worker-PowerKVM": a DNS-1123 subdomain must consist of lower case alphanumeric characters, '-' or '.', and must start and end with an alphanumeric character (e.g. 'example.com', regex used for validation is '[a-z0-9]([-a-z0-9]*[a-z0-9])?(\.[a-z0-9]([-a-z0-9]*[a-z0-9])?)*')
```

Additional info:
Reported by Yussuf Shaikh on Github: https://github.com/openshift/installer/issues/4069

Comment 4 David Sanz 2020-09-10 10:59:52 UTC
[morenod@morenod-laptop ~]$ openstack server list --long
+--------------------------------------+----------------------------+--------+------------+-------------+------------------------------------------+------------------------+--------------------------------------+-------------+--------------------------------------+-------------------+------+--------------------------------------------------------------------------+
| ID                                   | Name                       | Status | Task State | Power State | Networks                                 | Image Name             | Image ID                             | Flavor Name | Flavor ID                            | Availability Zone | Host | Properties                                                               |
+--------------------------------------+----------------------------+--------+------------+-------------+------------------------------------------+------------------------+--------------------------------------+-------------+--------------------------------------+-------------------+------+--------------------------------------------------------------------------+
| a1046d9d-3a02-436e-a666-95615d594a71 | mrnd-16-az-7xrsj-bootstrap | BUILD  | spawning   | NOSTATE     |                                          | mrnd-16-az-7xrsj-rhcos | 8c08ef19-aef9-4aa9-9d13-ecec8652c711 | m4.xlarge   | 2f84b564-7b31-4318-bb8d-3bb371778791 | AZ1               |      | Name='mrnd-16-az-7xrsj-bootstrap', openshiftClusterID='mrnd-16-az-7xrsj' |
| 556e9a9f-bda3-425e-8350-4097e851c224 | mrnd-16-az-7xrsj-master-0  | BUILD  | spawning   | NOSTATE     |                                          | mrnd-16-az-7xrsj-rhcos | 8c08ef19-aef9-4aa9-9d13-ecec8652c711 | m4.xlarge   | 2f84b564-7b31-4318-bb8d-3bb371778791 | AZ1               |      | Name='mrnd-16-az-7xrsj-master', openshiftClusterID='mrnd-16-az-7xrsj'    |
| b6282a4d-eb6a-403b-8457-5c9ac4db268c | mrnd-16-az-7xrsj-master-1  | ACTIVE | None       | Running     | mrnd-16-az-7xrsj-openshift=192.168.3.119 | mrnd-16-az-7xrsj-rhcos | 8c08ef19-aef9-4aa9-9d13-ecec8652c711 | m4.xlarge   | 2f84b564-7b31-4318-bb8d-3bb371778791 | AZ2               |      | Name='mrnd-16-az-7xrsj-master', openshiftClusterID='mrnd-16-az-7xrsj'    |
| c86d9259-ccad-4696-be97-ed347650155a | mrnd-16-az-7xrsj-master-2  | BUILD  | spawning   | NOSTATE     |                                          | mrnd-16-az-7xrsj-rhcos | 8c08ef19-aef9-4aa9-9d13-ecec8652c711 | m4.xlarge   | 2f84b564-7b31-4318-bb8d-3bb371778791 | AZ3               |      | Name='mrnd-16-az-7xrsj-master', openshiftClusterID='mrnd-16-az-7xrsj'    |
+--------------------------------------+----------------------------+--------+------------+-------------+------------------------------------------+------------------------+--------------------------------------+-------------+--------------------------------------+-------------------+------+--------------------------------------------------------------------------+

Comment 6 errata-xmlrpc 2020-10-27 16:29:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.