Bug 187009 - text-mode install fails in case of LVM setup; with a workaround
text-mode install fails in case of LVM setup; with a workaround
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-27 18:50 EST by Wojciech Pilorz
Modified: 2008-01-07 03:27 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-13 17:09:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my LVM setup: results of lvs, pvs and vgs command of lvm (868 bytes, text/plain)
2006-03-27 18:50 EST, Wojciech Pilorz
no flags Details

  None (edit)
Description Wojciech Pilorz 2006-03-27 18:50:46 EST
Description of problem:

I decided to install FC5 from CDRs on a P4 box with only 128 MB of RAM, so text
mode installation was the only option.
I created my LVM setup using lvm.static in bash virtual console;

Unfortunately the installer insisted on somehow removing logical disks from
/dev/mapper, even if I had run "lvm.static vgchange -ay";

That removing was just before making filesystems; then the installer could not
make a filesystem on first LV, displayed fatal error message and offered (the
only) option to reboot the system (no Back button, unfortunately);

I tried install again, made ext3 filesystmes on all LVs in bash virtual console,
 then installer again removed LVs from /dev/mapper just before trying to mount
filesystems on LVs, with result as before.

My workaround which allowed me to complete the installation was as follows:
after package dependency checking the installer displayed a box containg
something like "Press OK to start installation";
Before pressing OK I started on the bash virtual console the following loop:

while :; do echo -en .; lvm.static vgchange -ay; done

This allowed me to complete the installation of FC5 on this box
(I have killed the loop after filesystems had been mounted)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
LVM setup attached
Comment 1 Wojciech Pilorz 2006-03-27 18:50:46 EST
Created attachment 126865 [details]
my LVM setup: results of lvs, pvs and vgs command of lvm
Comment 2 David Cantrell 2006-09-13 17:09:30 EDT
Interesting workaround to get the text-mode installer to work for you.

It's unlikely that we'll fix this problem as the installer has three other
interfaces for configuring LVM:  kickstart, graphical mode, vnc mode.

In your case, a kickstart install would work great (and would be faster) that
running through the text mode installer.  The big problems with the text mode
installer is lack of screen space to display dialog boxes.  LVM gets complex and
it's hard to fit all that on the screen and still make it easy for the user to
understand.  VNC installs are best for the headless systems, but since you have
128MB of memory in this system, a kickstart install would be better.
Comment 3 Wojciech Pilorz 2006-10-31 08:58:41 EST
I did not insist on allowing to configure LVM in text mode installer;
I would just like it to tolerate LVM setup.
Note on kickstart heard, I would try that with FC6 soon.
Comment 4 Wojciech Pilorz 2008-01-07 03:27:19 EST
A few days ago I tried to install Fedora8 on a 256MB P4 box, using GUI
install.
The same problem (this time GUI installer)
and the same workaround needed to complete the installation.
Please see bug #221074 comment.

Note You need to log in before you can comment on or make changes to this bug.