Bug 1870158 - Reconciliation of MutatingWebhookConfiguration values didnt happen
Summary: Reconciliation of MutatingWebhookConfiguration values didnt happen
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Danil Grigorev
QA Contact: Milind Yadav
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-19 13:04 UTC by Milind Yadav
Modified: 2020-10-27 16:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:29:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-api-operator pull 707 0 None closed Bug 1870158: Use mergo to merge webhooks instead of custom apply 2020-10-27 05:59:03 UTC
Github openshift machine-api-operator pull 708 0 None closed Bug 1870158: Enforce webhooks service reference to port 443 2020-10-27 05:59:03 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:29:27 UTC

Description Milind Yadav 2020-08-19 13:04:12 UTC
Description of problem:
Reconciliation of MutatingWebhookConfiguration values didnt happen , even when the MAO deployment is scaled from 0 to 1 

Version-Release number of selected component (if applicable):
Cluster version is 4.6.0-0.nightly-2020-08-12-155346


How reproducible:
Always


Steps to Reproduce:
1.oc scale deployment cluster-version-operator -n openshift-cluster-version --replicas=0

2.Step 2:
scaled down mao -
oc scale deployment machine-api-operator  --replicas=0
[miyadav@miyadav debug]$ oc get deployment --config awskube

3.Updated the Mutating webhook with port 443->444
[oc edit MutatingWebhookConfiguration machine-api]

4.scale deployment of MAO to 1 
oc scale deployment machine-api-operator --replicas=1

Actual results:
Reconciliation of MutatingWebhookConfiguration values didnt happen

Expected results:
Reconciliation of MutatingWebhookConfiguration values should happen after MAO is scaled up.

Additional info:

Comment 2 Joel Speed 2020-09-22 11:36:38 UTC
While looking into this issue, I've realised that the port is not a currently managed field, yet it should be. I will raise a PR that fixes this specific issue. @Milind, if you were to change another value such as the path of the client config, would that be reconciled as expected?

Comment 4 Milind Yadav 2020-09-24 04:10:25 UTC
Validated at :
[miyadav@miyadav ManualRun]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-09-23-022756   True        False         16h     Cluster version is 4.6.0-0.nightly-2020-09-23-022756


@Joel , even after the PR the issue with port not getting reconciled is there . As suggested by you checked for the clientconfig path also , it doesnt reconcile as well

Comment 5 Joel Speed 2020-09-24 16:17:16 UTC
Thanks for the update Milind, we have two potential approaches, both with PRs already, which we believe will resolve this issue, we are currently discussing the merits of both approaches to try and decide which approach we should go ahead with.

Hopefully we should be able to get something approved and merged tomorrow

Comment 7 Milind Yadav 2020-09-28 04:28:46 UTC
VERIFIED ON  -
[miyadav@miyadav ~]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-09-27-075304   True        False         36m     Cluster version is 4.6.0-0.nightly-2020-09-27-075304

the webhooks values reconciled successfully , when machine-api-operator deployment was scaled from 0->1 .

Same steps are followed as mentioned on description

Comment 10 errata-xmlrpc 2020-10-27 16:29:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.