Bug 187020 - X won't change resolutions without restarting
X won't change resolutions without restarting
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-27 22:26 EST by its.a.thing
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-20 11:37:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my /etc/X11/xorg.conf (2.69 KB, text/plain)
2006-03-27 22:26 EST, its.a.thing
no flags Details
My /var/log/Xorg.0.log after attempting to switch resolutions in Nexuiz (72.52 KB, text/plain)
2006-03-28 14:01 EST, its.a.thing
no flags Details

  None (edit)
Description its.a.thing 2006-03-27 22:26:30 EST
Description of problem:
When I use an SDL program (such as Nexuiz, Frozen Bubble, Virus Killer, or
Project: Starfighter) it won't correctly switch to a resolution that is lower
than the first value specified in /etc/X11/xorg.conf for fullscreen mode.

Inconvenient work-around:
Set desired resolution to the first in xorg.conf.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.0.1-9

How reproducible:
every time

Hardware:
-Video card: ATI Radeon 9100
-Monitor: Envision EFT 720

Steps to Reproduce:
1. With above hardware, install and run Nexuiz on FC5.
2. Go to Options>Video and right click on Resolution to set it to something lower.
3. Use anything else made with SDL in fullscreen mode.

Actual results:
X stays in the same resolution, but the SDL program is just a rectangle in the
center of the screen the size of the resolution X should be.

Expected results:
X switches to the lower resolution and the SDL program takes up the whole screen.

Additional info:
1. kcmshell display only displays one resolution in the Screen size field.
2. Ctrl Alt +/- don't work.
3. I've tried copying my xorg.conf from FC4, but that didn't change anything.
Comment 1 its.a.thing 2006-03-27 22:26:30 EST
Created attachment 126874 [details]
my /etc/X11/xorg.conf
Comment 2 its.a.thing 2006-03-27 22:28:16 EST
I accidently submitted this with the wrong summary >.<
Comment 3 Mike A. Harris 2006-03-28 12:22:39 EST
Attach your X server log file.
Comment 4 its.a.thing 2006-03-28 14:01:03 EST
Created attachment 126920 [details]
My /var/log/Xorg.0.log after attempting to switch resolutions in Nexuiz
Comment 5 its.a.thing 2006-04-07 23:39:15 EDT
It's been over a week. Any news?
Comment 6 Matěj Cepl 2007-02-07 04:01:44 EST
Reporter, could you confirm please, that this bug still could be reproduced with
the latest release of Fedora (FC6)?
Comment 7 a thing 2007-04-19 22:24:59 EDT
Sorry I forgot about this bug, I've changed email addresses twice since I opened it.

Anyway, it doesn't persist in FC6.

Note You need to log in before you can comment on or make changes to this bug.