Bug 187023 - Grip segfaluts in Japanes locale
Grip segfaluts in Japanes locale
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: grip (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-27 23:05 EST by Mamoru TASAKA
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 06:17:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDB log of just launching grip (7.06 KB, text/plain)
2006-03-27 23:05 EST, Mamoru TASAKA
no flags Details

  None (edit)
Description Mamoru TASAKA 2006-03-27 23:05:44 EST
Description of problem:
Grip segfaluts in Japanese locale when just starting it.
GDB log is attached.

Version-Release number of selected component (if applicable):
grip-3.2.0-10.fc5

How reproducible:
100%

Steps to Reproduce:
1. Ensure that the locale is Japanese.
2. Just launch grip.
3.
  
Actual results:
Grip segfaults.

Expected results:
Should not segfault.

Additional info:
It seems that this due to the line 539 in src/grip.c.
Comment 1 Mamoru TASAKA 2006-03-27 23:05:45 EST
Created attachment 126876 [details]
GDB log of just launching grip
Comment 3 Adrian Reber 2006-03-30 06:17:09 EST
Fixed. In CVS and successfully built. Should be available with the next push.

Note You need to log in before you can comment on or make changes to this bug.