Bug 1870339 - Snapshot restore fails for RBD RWX PVC because volume mode is set to Filesystem by default
Summary: Snapshot restore fails for RBD RWX PVC because volume mode is set to Filesyst...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Kanika Murarka
QA Contact: Jilju Joy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-19 20:00 UTC by Jilju Joy
Modified: 2020-10-27 16:30 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:29:46 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot showing the error events (197.89 KB, image/png)
2020-08-19 20:00 UTC, Jilju Joy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6559 0 None closed Bug 1870339: Sets volumeMode as block for RBD+RWX 2020-10-05 13:15:08 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:30:01 UTC

Description Jilju Joy 2020-08-19 20:00:02 UTC
Created attachment 1711939 [details]
Screenshot showing the error events

Description of problem:
-----------------------
Creating a new PVC from the snapshot of a RBD RWX block volume mode PVC fails because the volume mode of new PVC is set to Filesystem in UI. The volume mode is default to Filesystem and cannot be edited. Restore will fail because RWX access mode is not supported on rbd filesystem type volumes.

Error :
failed to provision volume with StorageClass "ocs-storagecluster-ceph-rbd": rpc error: code = InvalidArgument desc = multi node access modes are only supported on rbd `block` type volumes




Version-Release number of selected component (if applicable):
-------------------------------------------------------------
Cluster version is 4.6.0-0.nightly-2020-08-18-165040
ocs-operator.v4.6.0-57.ci


How reproducible:
Always


Steps to Reproduce:
1. Create an rbd PVC with access mode RWX in UI. Volume mode will be set to Block.
2. Create a snapshot of the volume.
3. Try to restore from the created snapshot.

Actual results:
New PVC creation from snapshot fails because volume mode is set to Filesystem which is not a supported configuration for rbx rwx PVC.


Expected results:
-----------------
Volume mode should be set to the same value as in the parent PVC.


Additional info:

Comment 3 Jilju Joy 2020-09-29 06:04:28 UTC
Verified in version:
Cluster version is 4.6.0-0.nightly-2020-09-27-075304
ocs-operator.v4.6.0-98.ci

Snapshot restore of RBD RWX PVC and RBD RWO PVC was succeeded from UI.

Comment 6 errata-xmlrpc 2020-10-27 16:29:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.