Bug 1870378 - [DOC] add quotes to semver range example
Summary: [DOC] add quotes to semver range example
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Evan Cordell
QA Contact: Bruno Andrade
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-19 22:23 UTC by Bruno Andrade
Modified: 2020-10-27 16:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:29:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-registry pull 422 0 None open fix: add quotes to semver range example 2020-08-19 22:26:41 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:30:01 UTC

Description Bruno Andrade 2020-08-19 22:23:08 UTC
Description of problem:

https://github.com/operator-framework/operator-registry/blob/master/docs/design/operator-bundle.md#bundle-dependencies has a example on how to use semver with range as shown below:

dependencies:
  - type: olm.package
    value:
      packageName: prometheus
      version: >0.27.0
  - type: olm.gvk
    value:
      group: etcd.database.coreos.com
      kind: EtcdCluster
      version: v1beta2

Where >0.27.0 should be added between quote to avoid a yaml conversion issue.
 
Version-Release number of selected component (if applicable):
https://github.com/operator-framework/operator-registry/commit/3efef97a051c366bcd45ecc6c28d3d4522741a80#diff-ba4fcb6a5514edd925d1960cee5e7e33

How reproducible:
Always

Steps to Reproduce:
1. Try to index a bundle with dependencies.

Comment 5 errata-xmlrpc 2020-10-27 16:29:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.