Bug 1870467 - D/DC Part of Helm / Operator Backed should not have HPA
Summary: D/DC Part of Helm / Operator Backed should not have HPA
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.7.0
Assignee: Debsmita Santra
QA Contact: Mohammed Saud
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-20 07:34 UTC by Debsmita Santra
Modified: 2021-02-24 15:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-24 15:16:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6275 0 None open Bug 1870467: D/DC part of Helm/Operator backed should not have HPA 2020-09-30 12:51:41 UTC
Red Hat Product Errata RHSA-2020:5633 0 None None None 2021-02-24 15:16:33 UTC

Description Debsmita Santra 2020-08-20 07:34:26 UTC
Description of problem:
There isn't proper guards against D/DC nodes that are part of more complex groupings like Helm and Operator Backed. HPA is always available on D/DCs and it shouldn't be.

Version-Release number of selected component (if applicable):
4.6

How reproducible:
Always

Steps to Reproduce:
1. Add a stand-alone D and DC
2. Add a Helm chart with a D or DC
3. Add a Operator Backed service with a D or DC

Actual results:
Kebab action for "Add Horizontal Pod Autoscaler" is visible on all D/DCs

Expected results:
Kebab action for "Add Horizontal Pod Autoscaler" is ONLY visible on stand-alone D/DCs

Additional info:

Comment 1 Mohammed Saud 2020-10-01 13:57:55 UTC
Verified on -
Build: 4.6.0-0.nightly-2020-10-01-012547
User: kubeadmin
Browser: Firefox 81

Comment 4 errata-xmlrpc 2021-02-24 15:16:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.7.0 security, bug fix, and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2020:5633


Note You need to log in before you can comment on or make changes to this bug.