Bug 1870469 - Pipeline Run shows random Pod log messages if workspace is missing
Summary: Pipeline Run shows random Pod log messages if workspace is missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Mohammed Saud
QA Contact: Karthik Jeeyar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-20 07:40 UTC by Mohammed Saud
Modified: 2020-10-27 16:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:29:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6208 0 None closed Bug 1870469: Check for podName before displaying Task logs 2020-09-23 08:39:30 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:30:01 UTC

Description Mohammed Saud 2020-08-20 07:40:31 UTC
Description of problem:

When setting up a Pipeline manually the Pipeline Run failed (with the steps described below) which results in an unexpected Pipeline Run Status. When checking the logs for the Pipeline Run a "random" Pod log was shown to the user.
Prerequisites (if any, like setup, operators/versions):

    Install OpenShift Pipelines operator (tested with 1.0.1)

Steps to Reproduce

    Create a project / namespace
    Create at least one (or better more) other running pods (ex. from image jerolimov/nodeinfo)
    Create a pipeline (Pipeline > Create)
    1. Select Task "git-clone"
    2. Select Task "git-clone" and enter a Git url (ex. https://github.com/jerolimov/docker)
    3. Press create
    Run the new Pipeline and checkout the logs
    1. Select Action dropdown > Start
    2. Select the Logs tab
    You now see log messages from other pods!

Actual results:

    You now see log messages from other pods!

There was the following error messages part of the Pipeline run:

    Pipeline run message: TaskRun new-pipeline-6a827s-git-clone-bv7jp has failed
    TaskRun message: bound workspaces did not match declared workspaces: didn't provide required values: [output]

Expected results:

    Do not show an invalid pod log. Do not request Pods without a name filter.
    Show the correct log message, or at least an error message:
    Show the PipelineRun status condition message, or better the taskRun status condition message!

Reproducibility (Always/Intermittent/Only Once):

Always
Build Details:
Additional info:

Select your Pipeline Ruin Details and open the YAML.

Under "taskRuns xxx status" you can see that the "podName" is an empty (""). First analyse with Andrew Ballantyne shows that this is used to select "the first pod within your namespace" because the name filter was not applied.

See also packages/dev-console/src/components/pipelineruns/detail-page-tabs/PipelineRunLogs.tsx

Comment 3 Karthik Jeeyar 2020-09-23 10:57:31 UTC
Verification Details: 
Build: 4.6.0-0.nightly-2020-09-22-130743
url: https://console-openshift-console.apps.dev-svc-4.6-092307.devcluster.openshift.com/k8s/ns/rhd-test/tekton.dev~v1beta1~PipelineRun/nodejs-ex-mru0wv/logs
user: kubeadmin

Comment 5 errata-xmlrpc 2020-10-27 16:29:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.