Bug 1870536 - Operand list Status column doesn't show a icon when condition is failure
Summary: Operand list Status column doesn't show a icon when condition is failure
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Yadan Pei
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-20 10:06 UTC by Yadan Pei
Modified: 2020-10-27 16:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:29:46 UTC
Target Upstream Version:


Attachments (Terms of Use)
Condition Failure (156.29 KB, image/png)
2020-08-20 10:07 UTC, Yadan Pei
no flags Details
Condition Running (189.02 KB, image/png)
2020-08-20 10:07 UTC, Yadan Pei
no flags Details
Condition Failure has icon (139.04 KB, image/png)
2020-08-24 06:55 UTC, Yadan Pei
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6383 0 None open Bug 1870536: Add check 'Failure' condition to the Status component 2020-08-20 11:24:53 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:30:02 UTC

Description Yadan Pei 2020-08-20 10:06:55 UTC
Description of problem:
When status text is Condition: Failure, console doesn't show a icon

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-08-18-165040

How reproducible:
Always

Steps to Reproduce:
1. install Kiali Operator from OperatorHub and wait it to be succeed
2. create Kiali instance via OperatorHub -> Installed Operators -> Kiali Operator -> Kiali tab 
3. check Kiali instance status on Kaili tab

Actual results:
3. When it has a Condition: Failure status, we only show the text, the icon is missing

Expected results:
3. we should show both a icon and status text

Additional info:

Comment 1 Yadan Pei 2020-08-20 10:07:29 UTC
Created attachment 1711995 [details]
Condition Failure

no icon is shown

Comment 2 Yadan Pei 2020-08-20 10:07:59 UTC
Created attachment 1711996 [details]
Condition Running

a green ok icon is shown

Comment 5 Yadan Pei 2020-08-24 06:55:38 UTC
Created attachment 1712301 [details]
Condition Failure has icon

Now when condition is Failure, console shows a red danger icon

Verified on 4.6.0-0.nightly-2020-08-23-185640

Comment 7 errata-xmlrpc 2020-10-27 16:29:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.