Bug 1870606 - Error message for self provisioner while fetching bootstrap servers/topics
Summary: Error message for self provisioner while fetching bootstrap servers/topics
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: divgupta
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-20 13:23 UTC by divgupta
Modified: 2020-10-27 16:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:29:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6301 0 None closed Bug 1870606: Update error message for bootstrapServers and topics 2020-09-02 13:52:55 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:30:00 UTC

Description divgupta 2020-08-20 13:23:01 UTC
Description of problem:
Currently if a user doesn't have access/required permission for fetching bootstrapServers/topics we show the error inline as in attached screenshot and looks confusing to user as still they can type multiple bootstrapServers/Topics

How reproducible: Always

Steps to Reproduce:
1.Login as seflProvisoner
2.Create a NS
3.Go to DevPerspective -> Add -> EventSource
4.Select KafkaSource

Actual results:
can see error inline for failure with fetching bootstrap Server

Expected results:
Message should be more intuitive as failure looks like an issue as still user can manually add bootstrap Servers/topics.

Comment 4 errata-xmlrpc 2020-10-27 16:29:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.