Bug 1870632 - SBR connector should have context menu on right click
Summary: SBR connector should have context menu on right click
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-20 13:42 UTC by Jeff Phillips
Modified: 2020-10-27 16:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.6.0-0.nightly-2020-08-18-165040 Cluster ID: f844bc36-a328-4dd9-adab-842f0051a000 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.135 Safari/537.36
Last Closed: 2020-10-27 16:29:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
SBR connector have context menu on right click (74.21 KB, image/png)
2020-08-24 12:59 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6281 0 None closed Bug 1870632: Add context menu and details panel for SBRs in topology 2020-09-03 11:47:55 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:30:00 UTC

Description Jeff Phillips 2020-08-20 13:42:18 UTC
Description of problem:

All the resource backed edges should have the context menu. Eg: Subscription, Triggers are having the context menu on right click, similarly SBR should have it too.

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:

1. Service Binding Operator has to be installed
2. Create a Deployment/DeploymentConfig and a operator backed service
3. Connect the D/DC with the Operator backed service using the SBR
4. Right click on the SBR edge

Actual results:

Context menu is missing on SBR edge

Expected results:

SBR edge in the topology is resource based edge, so it should have the context menu on the right click.

Additional info:

Comment 4 Gajanan More 2020-08-24 12:24:16 UTC
I have validated the bugzilla on:

Build: 4.6.0-0.nightly-2020-08-23-214712

Browser: Google Chrome Version 84.0.4147.89 

Marking this as verified

Comment 5 spathak@redhat.com 2020-08-24 12:59:03 UTC
Created attachment 1712356 [details]
SBR connector have context menu on right click

Comment 7 errata-xmlrpc 2020-10-27 16:29:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.