Bug 1870634 - Topology Filtering Off and On Application Groups Has a Slow Reaction Time
Summary: Topology Filtering Off and On Application Groups Has a Slow Reaction Time
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Jeff Phillips
QA Contact: Jaivardhan Kumar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-20 13:44 UTC by Jeff Phillips
Modified: 2020-10-27 16:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.6.0-0.nightly-2020-08-18-165040 Cluster ID: f844bc36-a328-4dd9-adab-842f0051a000 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.135 Safari/537.36
Last Closed: 2020-10-27 16:30:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6341 0 None closed Bug 1870634: Fix slow reaction time on topology filter changes 2020-08-26 09:55:02 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:30:26 UTC

Description Jeff Phillips 2020-08-20 13:44:57 UTC
Description of problem:

When filtering out resources that are all in the same application group, the group disappears with the nodes. If you re-enable them back, the group sometimes takes a moment to re-render and thus the nodes are separate.


Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:

1. Add a couple Deployments to the same group
2. Add another resource type
3. Filter to the other resource type (thus removing the Deployments)
4. Then remove the filters

Actual results:

The deployments were grouped, hidden, then ungrouped for a short period of time before the group re-renders around the deployments.

Expected results:

The group to immediately return when the deployments do

Additional info:

Comment 4 Jaivardhan Kumar 2020-08-26 09:55:26 UTC
Verified on 4.6.0-0.nightly-2020-08-26-032807

Comment 6 errata-xmlrpc 2020-10-27 16:30:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.