Bug 18707 - Unable to inspect symbols
Unable to inspect symbols
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
: 22671 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-09 08:59 EDT by Marius Kintel
Modified: 2005-10-31 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-31 06:14:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Kintel 2000-10-09 08:59:05 EDT
Compile the following program: g++ -g test.cpp -o test

#include <stdio.h>

int main(int argc, char *argv[])
{
  for (int i=0;i<10;i++) {
    int test = i;
    printf("%d\n",test);
  }

}

Try running the program in gdb, break it at the printf-line.
Try inspecting the variables i and test. This does not work on my
plain RH7.0-box.
Comment 1 Trond Eivind Glomsrxd 2000-10-09 10:19:39 EDT
Daniel, could you take a look at this? I've confirmed the problem...

I'm not sure that gdb tries to handle locally instatiated variables, though.
Comment 2 Marius Kintel 2000-10-09 10:40:42 EDT
I compiled the same program on a RH6.2-box (using egcs-2.91.66).
Debugging that executable under RH7.0 works fine, so it looks like
it's g++'s fault.
Comment 3 Trond Eivind Glomsrxd 2000-10-09 10:52:27 EDT
Looks like it... Jakub?
Comment 4 Jakub Jelinek 2000-12-31 06:08:14 EST
Richard Henderson fixed this in
http://gcc.gnu.org/ml/gcc-patches/2000-12/msg01445.html
It will appear in gcc-2.96-70
Comment 5 Jakub Jelinek 2000-12-31 06:14:52 EST
*** Bug 22671 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.