Bug 1870805 - Inconsistent pod donut text for knative service in topology and sidebar details
Summary: Inconsistent pod donut text for knative service in topology and sidebar details
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-20 19:04 UTC by Jaivardhan Kumar
Modified: 2020-10-27 16:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:30:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6391 0 None closed Bug 1870805: fixes inconsistent pod donut status for knsvc 2020-09-02 13:22:05 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:30:26 UTC

Description Jaivardhan Kumar 2020-08-20 19:04:39 UTC
Description of problem: Inconsistent pod donut text for knative service in topology and sidebar details


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Install Serverless operator
2. Go to dev Perspective -> Add -> container image 
3. Deploy any image as knative service and create

Actual results: In Topology view can see Donut status text is "Scaled to 0" however on sidebar it says "Autoscaled to 0"


Expected results:Donut status text for knative service should be consistent across and say "Autoscaled to 0"


Additional info:

Comment 1 Jaivardhan Kumar 2020-08-20 19:07:48 UTC
https://issues.redhat.com/browse/ODC-4514

Comment 4 cvogt 2020-09-02 13:39:19 UTC
Browser: 84.0.522.61 (Official build) (64-bit)
Build: 4.6.0-0.nightly-2020-08-23-214712

After fix, knative Revisions now correctly show the `autoscaled to 0` label in the pod donut.

Comment 6 errata-xmlrpc 2020-10-27 16:30:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.