Bug 187093 - Every second reinstall fails on a ProLiant DL580 G2 (vgcreate fails for rootvg)
Every second reinstall fails on a ProLiant DL580 G2 (vgcreate fails for rootvg)
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Depends On:
  Show dependency treegraph
Reported: 2006-03-28 09:05 EST by Dag Wieers
Modified: 2014-08-06 06:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-19 14:45:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Kickstart file that causes the behaviour on a ProLiant DL580 G2 (3.23 KB, text/plain)
2006-03-28 09:05 EST, Dag Wieers
no flags Details
Kickstart file on DL585 G2 which fails on system with existing VGs (3.77 KB, text/plain)
2006-05-15 09:43 EDT, Ajitabh Pandey
no flags Details
Anaconda dump file for the kickstart which failed on DL585 G2 (713.58 KB, text/plain)
2006-05-15 09:45 EDT, Ajitabh Pandey
no flags Details

  None (edit)
Description Dag Wieers 2006-03-28 09:05:56 EST
Description of problem:
As reported in https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=186599 every
second reinstall fails on a ProLiant DL580 G2.

It seems to have to do with the following commands in the kickstart file:

     clearpart --all
     clearpart --initlabel

After a successful installation, a reinstall appears to fail on one of these
commands, but on a second reinstall it overcomes this problem. So when doing
multiple reinstalls on the same machine we always have it fail every other time.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Dag Wieers 2006-03-28 09:05:56 EST
Created attachment 126903 [details]
Kickstart file that causes the behaviour on a ProLiant DL580 G2
Comment 2 Jeremy Katz 2006-04-10 12:19:04 EDT
How does it fail?  Can you provide the anacdump.txt?
Comment 3 Dag Wieers 2006-05-15 08:58:19 EDT
I don't have an anacdump.txt and the systems have been put in production a few
days later. So I cannot help debugging.
Comment 4 Ajitabh Pandey 2006-05-15 09:38:02 EDT
I am also experiencing something similar on a HP DL585 G2 system with external
disk trays.  I am attaching my kickstart file also. I get a very long error
message, the last few lines of which are: 

SystemError: pvcreate failed for <fsset PartitionDevice instance at

The system on which I am trying to run the kickstart already has VGs on both the
internal disks and as well as on the external disk tray. The first time when the
 system was fresh (with no VGs on any disk) the kickstart worked fine. After
that, I have run the same kickstart several times and have found that it failed
exactly at the same point (while trying to create PVs). However, I have observed
that if I comment out the line "text", the installer runs in graphical mode and
works absolutely fine everytime.

To me it looks like the 

clearpart --all
clearpart --initlabel

does not seem to function properly with cciss driver in text mode install.

I am also attaching the anacdump.txt file for your reference. I can afford to
keep the system out of production for a short time, so if you need any more
information, please get back.
Comment 5 Ajitabh Pandey 2006-05-15 09:43:53 EDT
Created attachment 129054 [details]
Kickstart file on DL585 G2 which fails on system with existing VGs

This is the kickstart file which fails when the DL585 G2 system using cciss
driver already has VGs on it. It looks like clearpart --all --initlabel is not
clearing the partitions.
Comment 6 Ajitabh Pandey 2006-05-15 09:45:38 EDT
Created attachment 129055 [details]
Anaconda dump file for the kickstart which failed on DL585 G2

This is the anaconda dump file when the installation failed.
Comment 7 Ajitabh Pandey 2006-05-18 11:45:20 EDT
This is coming out to be a surprise now, The second install when I commented out
the line "text" in kickstart file, the installation successed. Third
installation, it is not working. Same message which appears in text mode
kickstart is now appearing in graphics mode install and at the same place.

I had tried doing 

dd if=/dev/zero of=/dev/cciss/c0d0 bs=512 count=1
dd if=/dev/zero of=/dev/cciss/c1d[0-4] bs=512 count=1

This should have removed any LVM signatures from the array. But still the same
result. Now I am stuck, both text and gui kickstart modes dont work.

Can this be looked into priority mode.
Comment 8 Ajitabh Pandey 2006-05-19 06:19:32 EDT
Ok, I think I have now understood what's the problem. I rebuild the RAID by
revisiting the BIOS utilities. First I did it with the internal disks based on
SmartArray 5i, but the kickstart still failed while trying to create a PV. Next
I rebuild the RAID on both SmartArray 5i and SmartArray 6400 and the
installation worked like a charm.
Comment 10 RHEL Product and Program Management 2007-10-19 14:45:43 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
For more information of the RHEL errata support policy, please visit:
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.
Comment 11 David Andruczyk 2009-06-03 22:06:56 EDT

This bug EXISTS in RHEL5.3.  I find though that I can't reinstall an exisitng system via kickstart if the original had LVM.

I have to manually blow the partition tbale top smitherines.

dd if=/dev/zero of=/dev/sda bs=1M count=1000 ; sync ; reboot

then kickstart again and all is well and the installation proceeds normally..

kickstart config used for partitioning the disks

zerombr yes
clearpart --initlabel --drives=sda --all
part /boot --fstype ext3 --size=200
part pv.2 --size=0 --grow --ondisk=sda
volgroup VolGroup00 --pesize=32768 pv.2
logvol / --fstype ext3 --name=LogVol00 --vgname=VolGroup00 --size=1024 --grow
logvol swap --fstype swap --name=LogVol01 --vgname=VolGroup00 --size=1000 --grow

Note You need to log in before you can comment on or make changes to this bug.