Bug 187096 - Computer not bootable after install
Computer not bootable after install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-28 09:15 EST by Norman R. Weathers
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 23:19:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Norman R. Weathers 2006-03-28 09:15:04 EST
Description of problem:


Version-Release number of selected component (if applicable):
(N/A)

How reproducible:
Everytime

Steps to Reproduce:
1. Install
2. Reboot
3. Watch initrd blow up
  
Actual results:
initrd fails to find /proc /sys or root devices using standard kernel with FC5.
Situation gets a little better if I jump up to a 2.6.16 kernel and down grade
the initrd to use mkinitrd rpm from FC4.  No longer complains about not being
able to find  /proc or /sys, but still cannot finish boot process due to invalid
argument during switchroot.

Expected results:
expected to complete initrd as it did in FC4

Additional info:

I have tried to debug this.  I have taken out the initrd (fails to boot due to
not being able to find a console).  I have tried to look into the initrd during
rescue mode.  I have downgraded mkinitrd to the FC4 mkinitrd.  I have compared
the initrd to my FC5 i386 laptop, and they use the same semantics (no different
arguments).

If I use the FC5 based kernel and initrd, I get the following (forgive the
transcribed typing...)

...
...
...  Device drivers are loading...  Lots of SCSI cards and stuff going on here.
...  All of this seems ok
...

Mounting root filesystem.
EXT3-fs:  INFO:  recovery required on readonly filesystem
EXT3-fs:  write access will be enabled during recovery
JDB:  no valid journal superblock found
EXT3-fs:  error loading journal
mount:  error mounting /dev/root on /sysroot as ext3:  Invalid argument
Setting up other filesystems.
Setting up new root fs
setuproot:  moving /dev/failed:  No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc:  No such file or directory
setuproot: error mounting /sys:  No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed:  Attempted to kill init!

Then it goes off into a panic...

It looks like it can't find my real root correctly, but it finds it just fine
whenever I have to use rescue to go in and find out what is wrong....

It is wierd.

But like I said, the minute I pop in the rescue CD, it finds it with no problem.

Any thoughts would be very helpful

(I do have multiple drives on this box, and I have told grub and the /etc/fstab
that the / filesystem is on /dev/hda2.)

Thank you in advance.

Note You need to log in before you can comment on or make changes to this bug.