This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 187102 - xorg-x11-deprecated-libs not supplied
xorg-x11-deprecated-libs not supplied
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
5
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-28 10:19 EST by Carl Parrish
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 18:15:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carl Parrish 2006-03-28 10:19:36 EST
Description of problem:
xorg-x11-deprecated-libs doesn't seem to be in any FC5 repos. Its needed to
install Zend Studio. I installed libXp-devel but it didn't seem to help any.  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.yum install xorg-x11-deprecated-libs
2.
3.
  
Actual results:
No Match for argument: xorg-x11-deprecated-libs


Expected results:
install successful


Additional info:
Comment 1 Mike A. Harris 2006-04-03 20:31:54 EDT
Nothing should ever be forcibly requiring xorg-x11-deprecated-libs.  rpm
autodetects shared libraries and adds dependencies on runtime shared libs
to packages that need them.

If Zend Studio has any "Requires: xorg-x11-deprecated-libs" lines in its
spec file, it is mispackaged, and that line should be removed.
Comment 2 Mike A. Harris 2006-04-03 20:34:10 EDT
Please attach the Zend Studio rpm spec file, or a URL to it.

Anything that links to libXp, should have a single buildrequires of:

BuildRequires: libXp-devel

There should be no "Requires: libXp" present, nor of the deprecated-libs
package.  If either are present, that is a packaging bug in the 3rd party
software.
Comment 3 Mike A. Harris 2006-05-18 18:15:06 EDT
Closing as NOTABUG, as it is intentional that this package is not supplied.
The proper solution to problems that occur as a result of this is outlined
in comment #2.

Comment 4 Carl Parrish 2006-05-19 00:13:31 EDT
The solution I was given by Zend is as follows

$ cd /usr/local/Zend/ZendStudioClient-5.1.0/bin

$ cp ZDE ZDE.bak

$ cat ZDE.bak | sed "s/export LD_ASSUME_KERNEL/#xport LD_ASSUME_KERNEL/" > ZDE

$ rm ZDE.bak

This worked, I guess it wasn't really a RH bug but since that was my fix in FC4
I thought I needed it. Thanks.

Note You need to log in before you can comment on or make changes to this bug.