Bug 1871088 - React warning when starting latest dev console in react dev mode
Summary: React warning when starting latest dev console in react dev mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Christoph Jerolimov
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-21 10:11 UTC by Christoph Jerolimov
Modified: 2020-10-27 16:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:30:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6162 0 None closed Bug 1871088: Fix react warning in navigation rendering (invalid html props) 2020-09-02 13:44:28 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:30:29 UTC

Description Christoph Jerolimov 2020-08-21 10:11:23 UTC
Description of problem:
When starting the latest dev console in dev mode (react) and open the browser console there are two react warnings (logged as errors):

* Warning: React does not recognize the activeNamespace prop on a DOM element. If you intentionally want it to appear in the DOM as a custom attribute, spell it as lowercase activenamespace instead. If you accidentally passed it from a parent component, remove it from the DOM element.
* Warning: Invalid value for prop dispatch on tag. Either remove it from the element, or pass a string or number value to keep it in the DOM. For details, see https://fb.me/react-attribute-behavior

Version-Release number of selected component (if applicable):
master after https://github.com/openshift/console/pull/6011 was merged

How reproducible:
Always

Steps to Reproduce:
1. Just open the developer console and open the browser console, optional refresh the current page

Actual results:
Two react warnings was logged

Expected results:
There should be no react warnings on each start

Additional info:
none

Comment 1 Christoph Jerolimov 2020-08-21 10:12:17 UTC
Jira Issue: https://issues.redhat.com/browse/ODC-4409
PR: https://github.com/openshift/console/pull/6162

Comment 5 errata-xmlrpc 2020-10-27 16:30:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.