Bug 1871355 - fakeroot testsuite is failing with glibc-2.32+
Summary: fakeroot testsuite is failing with glibc-2.32+
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fakeroot
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominik 'Rathann' Mierzejewski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-22 17:26 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2020-10-09 15:01 UTC (History)
4 users (show)

Fixed In Version: fakeroot-1.25.2-1.fc33 fakeroot-1.25.2-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-06 14:05:07 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Debian BTS 940056 0 None None None 2020-09-02 11:13:52 UTC
Debian BTS 968868 0 None None None 2020-08-22 19:00:18 UTC

Description Dominik 'Rathann' Mierzejewski 2020-08-22 17:26:18 UTC
Description of problem:
glibc update to 2.31.9000-1.fc33 seems to have caused three tests to fail:
FAIL: t.chmod_dev
FAIL: t.mknod
FAIL: t.touchinstall

Version-Release number of selected component (if applicable):
1.24-5.fc33

How reproducible:
Always

Steps to Reproduce:
1. Try building fakeroot-1.24-5.fc33.

Actual results:
...
========================================
   fakeroot 1.24: test/test-suite.log
========================================
# TOTAL: 12
# PASS:  9
# SKIP:  0
# XFAIL: 0
# FAIL:  3
# XPASS: 0
# ERROR: 0
.. contents:: :depth: 2
FAIL: t.chmod_dev
=================
-rw-r--r-- 1 mockbuild mock 0 Aug 22 17:14 t.chmod_dev.dir/hda3
FAIL t.chmod_dev (exit status: 1)
FAIL: t.mknod
=============
-rw-r--r-- 1 mockbuild mock 0 Aug 22 17:14 t.mknod.dir/hda3
FAIL t.mknod (exit status: 1)
FAIL: t.touchinstall
====================
-rw-r--r-- 1 mockbuild mock 0 Aug 22 17:14 t.touchinstall.dir/iamnotuser
FAIL t.touchinstall (exit status: 1)

Expected results:
All tests PASS.

Additional info:
Koschei is showing it started with glibc update to 2.31.9000-1.fc33:
https://koschei.fedoraproject.org/package/fakeroot?last_seen_ts=1585579576&collection=f34

Comment 1 Dominik 'Rathann' Mierzejewski 2020-09-02 11:13:52 UTC
Apparently, it's due to debian#940056 "fakeroot does not fake statx()":

The three failing tests parse the output of `ls -l`.

From NEWS.gz in coreutils (8.32-3) :

  stat and ls now use the statx() system call where available, which can
  operate more efficiently by only retrieving requested attributes.

Comment 2 Fedora Update System 2020-10-05 20:05:07 UTC
FEDORA-2020-09a16cf0d9 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-09a16cf0d9

Comment 3 Fedora Update System 2020-10-05 20:05:08 UTC
FEDORA-2020-a23c7e7112 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-a23c7e7112

Comment 4 Fedora Update System 2020-10-06 01:15:28 UTC
FEDORA-2020-09a16cf0d9 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-09a16cf0d9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-09a16cf0d9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2020-10-06 01:25:19 UTC
FEDORA-2020-a23c7e7112 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-a23c7e7112`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-a23c7e7112

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2020-10-06 14:05:07 UTC
FEDORA-2020-09a16cf0d9 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Fedora Update System 2020-10-09 15:01:12 UTC
FEDORA-2020-a23c7e7112 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.