Bug 187137 - enabling ntp changes /etc/ntp.conf without reason
enabling ntp changes /etc/ntp.conf without reason
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-28 14:03 EST by feily
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 12:58:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description feily 2006-03-28 14:03:14 EST
Description of problem:
enabling ntp adds a "restrict ... nomodify notrap noquery" line for every
server. Thats not usefull since the default ntp.conf has a line: "restrict
default nomodify notrap noquery".

Version-Release number of selected component (if applicable):
system-config-date-1.8.2-1

How reproducible:
always.

Steps to Reproduce:
1. enable ntp with a default configuration

Actual results:
adds
restrict 0.pool.ntp.org mask 255.255.255.255 nomodify notrap noquery
restrict 1.pool.ntp.org mask 255.255.255.255 nomodify notrap noquery
restrict 2.pool.ntp.org mask 255.255.255.255 nomodify notrap noquery
to /etc/ntp.conf

Expected results:
something like chkconfig ntpd on && service ntpd start, nothing else

Additional info:

Note You need to log in before you can comment on or make changes to this bug.