Bug 187153 - Xfce4-panel unstable when weather plugin is loaded
Xfce4-panel unstable when weather plugin is loaded
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xfce4-weather-plugin (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-28 15:43 EST by Erich Schroeder
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.5.99.1-3.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-20 07:17:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
I had started the panel from command line, this is what shows up when panel aborts (4.02 KB, text/plain)
2006-03-28 15:43 EST, Erich Schroeder
no flags Details

  None (edit)
Description Erich Schroeder 2006-03-28 15:43:58 EST
Description of problem:
Xfce4-panel appears to consistently fail when the weather plugin is included. It
works fine when the plugin is initially added, and correctly queries the weather
information (zip code 62563). At some point the panel will terminate, perhaps
when it checks again (maybe only if the screen saver is on?)

Version-Release number of selected component (if applicable):
[root@harpo changes-hub]# rpm -qa | grep xfce
xfce4-panel-4.2.3-3.fc5
xfce4-windowlist-plugin-0.1.0-5.fc5
xfce4-showdesktop-plugin-0.4.0-5.fc5
libxfcegui4-4.2.3-4.fc5
xfce4-datetime-plugin-0.3.1-6.fc5
xfce4-fsguard-plugin-0.2.1-3.fc5
xfce4-icon-theme-4.2.3-2.fc5
libxfce4util-4.2.3.2-2.fc5
xfce4-session-4.2.3-3.fc5
gtk-xfce-engine-2.2.8-2.fc5
xfce4-xmms-plugin-0.3.1-5.fc5
xfce4-weather-plugin-0.4.9-5.fc5
xfce4-cpugraph-plugin-0.2.2-5.fc5
xfce4-iconbox-4.2.3-3.fc5
xfce4-mount-plugin-0.3.3-2.fc5
xfce4-genmon-plugin-1.1-5.fc5
xfce4-taskmanager-0.3.1-3.fc5
xfce4-notes-plugin-0.11.1-3.fc5
xfce4-quicklauncher-plugin-0.81-3.fc5
xfce-mcs-manager-4.2.3-2.fc5
xfce4-mixer-4.2.3-2.fc5
xfce-utils-4.2.3-3.fc5
xfce4-screenshooter-plugin-0.0.8-2.fc5
xfce4-websearch-plugin-0.1.0-5.fc5
xfce4-systemload-plugin-0.3.6-5.fc5
libxfce4mcs-4.2.3-5.fc5
xfce4-appfinder-4.2.3-2.fc5
xfce4-systray-4.2.3-2.fc5
xfce-mcs-plugins-4.2.3-3.fc5
xfce4-diskperf-plugin-1.5-5.fc5
xfce4-sensors-plugin-0.7.0-4.fc5
xfce4-netload-plugin-0.3.3-5.fc5
xfce4-minicmd-plugin-0.3.0-5.fc5
[root@harpo changes-hub]#



How reproducible:


Steps to Reproduce:
1. Start xfce4-panel
2. Add weather plugin, set to zip code 62563, imperial measures, temp only
3. Wait some time
  
Actual results:

xfce4-panel terminates
on restarting it, the weather plugin is not included

Expected results:

xfce4-panel should keep running

Additional info:

I'll attach the error messages that I have.
Comment 1 Erich Schroeder 2006-03-28 15:43:58 EST
Created attachment 126933 [details]
I had started the panel from command line, this is what shows up when panel aborts
Comment 2 Kevin Fenzi 2006-03-29 11:31:21 EST
I am trying to duplicate this issue here.

Also added to CC the owner of the xfce4-weather-plugin. 

I'm not sure how this was assigned to than at redhat.com, 
unless he wants to take it. :) 

Comment 3 Kevin Fenzi 2006-03-29 11:34:17 EST
This may well be this upstream bug in the weather plugin: 

http://bugzilla.xfce.org/show_bug.cgi?id=1590

Comment 4 Erich Schroeder 2006-03-31 10:21:12 EST
Now I'm not sure of the connection with the weather plugin. I was away from my
computer for 24-30 hours, and when I came back, the xfce4-panel application had
died. The weather plugin had NOT been added to the panel. I unfortunately don't
have any log messages on this. Might it have been connected with the screensaver? 
Comment 5 Kevin Fenzi 2006-03-31 11:23:31 EST
Are there any messages in your /tmp/xses-* that look applicable?

I have been able to duplicate the crash with the weather plugin here. 
You simply load it and configure it, then try and remove it. 
That crashes the panel every time here. Can you duplicate it there?

There shouldn't be any interactive between the panel and the screensaver that 
I can think of. 

What other plugins do you have loaded in your panel?
Comment 6 Erich Schroeder 2006-03-31 13:46:09 EST
The xses file that might have had the info was already gone when I looked for it.

I find like you that just adding the weather plugin, configuring it to
something, and then removing it kills the panel.

My panel has: 
Terminal (reconfigured to start gnome-terminal
File Manager
Firefox
Music Player (reconfigured to start beep-media-player)
A launcher that starts an ssh system to my mail server
Settings
Printer (never used it)
Help
Lock the Screen (will eventually remove it)
Logoff
Time/clock
Netload
XMMS control (set to use BMP)

When I start xfce4-panel I get a message:

[erich@harpo tmp]$ xfce4-panel &
[1] 3536
[erich@harpo tmp]$
(xfce4-panel:3536): Gtk-CRITICAL **: gtk_progress_set_percentage: assertion `per
centage >= 0 && percentage <= 1.0' failed
[erich@harpo tmp]$

I tend to also see many "Gtk-CRITICAL" messages on other programs, including jpilot

[erich@harpo tmp]$ jpilot
  ***Then I click on Memo Pad and the following show up.
(jpilot:3557): Gdk-CRITICAL **: gdk_drawable_get_depth: assertion
`GDK_IS_DRAWABLE (drawable)' failed

(jpilot:3557): Gtk-CRITICAL **: gtk_pixmap_set: assertion
`gdk_colormap_get_visual (gtk_widget_get_colormap (GTK_WIDGET (pixmap)))->depth
== gdk_drawable_get_depth (GDK_DRAWABLE (val))' failed

(jpilot:3557): Gdk-CRITICAL **: gdk_drawable_get_depth: assertion
`GDK_IS_DRAWABLE (drawable)' failed

(jpilot:3557): Gtk-CRITICAL **: gtk_pixmap_set: assertion
`gdk_colormap_get_visual (gtk_widget_get_colormap (GTK_WIDGET (pixmap)))->depth
== gdk_drawable_get_depth (GDK_DRAWABLE (val))' failed

(jpilot:3557): Gdk-CRITICAL **: gdk_drawable_get_depth: assertion
`GDK_IS_DRAWABLE (drawable)' failed

(jpilot:3557): Gtk-CRITICAL **: gtk_pixmap_set: assertion
`gdk_colormap_get_visual (gtk_widget_get_colormap (GTK_WIDGET (pixmap)))->depth
== gdk_drawable_get_depth (GDK_DRAWABLE (val))' failed

(jpilot:3557): Gdk-CRITICAL **: gdk_drawable_get_depth: assertion
`GDK_IS_DRAWABLE (drawable)' failed

(jpilot:3557): Gtk-CRITICAL **: gtk_pixmap_set: assertion
`gdk_colormap_get_visual (gtk_widget_get_colormap (GTK_WIDGET (pixmap)))->depth
== gdk_drawable_get_depth (GDK_DRAWABLE (val))' failed

I mention jpilot because I have also had that crash on me, causing loss of
memopad records. I was going to submit this once I had some memory information
to include. But, I was wondering if these might be connected Gtk problems?
Comment 7 Kevin Fenzi 2006-03-31 14:04:34 EST
> The xses file that might have had the info was already gone when I looked for it.

Oh well. 

> I find like you that just adding the weather plugin, configuring it to
> something, and then removing it kills the panel.

So this looks like that upstream weather plugin bug. 
Can you run without the weather plugin and see if that causes your panel to be
stable. If so, I will re-assign this to the xfce4-weather-plugin. 

The jpilot issue sounds like: 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=160757
Make sure you have the updated pilot-link. 
Comment 8 Christoph Wickert 2006-04-01 17:14:36 EST
(In reply to comment #0)
> Description of problem:
>   
> xfce4-panel terminates
> on restarting it, the weather plugin is not included

(In reply to comment #4)
> Now I'm not sure of the connection with the weather plugin. I was away from my
> computer for 24-30 hours, and when I came back, the xfce4-panel application had
> died. The weather plugin had NOT been added to the panel.

Just to get this clear: Did you logout or shutdown xfce4-panel cleanly _after_
adding the weather-panel? If the panel crashed the config is not stored and
recently added plugins are lost. This doesn't necessarily mean the crash is
related to the plugin.

I'm trying to reproduce this here. I manged to crash the panel once when I added
_lots_ of information to the weather-plugin. I usually use only one line because
(I don't like the animation) and the panel runs fine for hours, no problems with
screensaver etc.

Nevertheless I'm going to build a test-package with the patch from comment #3.
Stay tuned.
Comment 9 Christoph Wickert 2006-04-01 18:04:44 EST
Updated Packages are available at
http://home.arcor.de/christoph.wickert/fedora/extras/

Please test them. Don't forget install the debuginfo, too.

NOTE: These are no official FE packages. They are signed with this key:
http://home.arcor.de/christoph.wickert/fedora/RPM-GPG-KEY-fedora-wickert
Comment 10 Christoph Wickert 2006-04-02 10:21:10 EDT
No Joy. I just realized the updated weather-plugin is crashing my panel.
Comment 11 Kevin Fenzi 2006-04-06 11:58:59 EDT
FYI, The debian report of this issue (
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=358249 ) includes a 
workaround until they can fix the weather plugin: 

"A work around is to launch: G_SLICE=always-malloc xfce4-panel"
Comment 12 Kevin Fenzi 2006-04-20 16:37:24 EDT
I am going to reassign this to the xfce4-weather-plugin component. 
Let me know if I can do anything further to assist... 
Comment 13 Christoph Wickert 2007-06-20 07:17:09 EDT
Just for the record: This was fixed in wavelan-plugin-0.5.99.1, which is available
in FE since Oct 5th, 2006. Unfortunately I cannot offer a solution for FC5,
because XFCE 4.2.x is no longer in development.

I'm upgrading this bug to FC6 now and then close it CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.