Bug 1871736 - [UI] Cloning of pvcs with block volume mode is not working
Summary: [UI] Cloning of pvcs with block volume mode is not working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Kanika Murarka
QA Contact: Elena Bondarenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-24 07:19 UTC by Elena Bondarenko
Modified: 2020-10-27 16:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:31:21 UTC
Target Upstream Version:


Attachments (Terms of Use)
Events log of rbd pvc's clone with the error (114.41 KB, image/png)
2020-08-26 11:14 UTC, Elena Bondarenko
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6630 0 None closed Bug 1871736: Fixes clone for block mode PVCs 2020-10-05 14:07:54 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:31:23 UTC

Description Elena Bondarenko 2020-08-24 07:19:52 UTC
Description of problem:

When I try to clone a pvc with block volume mode, I get error "failed to provision volume with StorageClass "ocs-storagecluster-ceph-rbd": error getting handle for DataSource Type PersistentVolumeClaim by Name rbdpvc: the source PVC and destination PVCs must have the same volume mode for cloning. Source is Block, but new PVC requested Filesystem"


Version-Release number of selected component (if applicable):

4.6.0-0.nightly-2020-08-23-214712
ocs-operator.v4.6.0-535.ci


How reproducible:

100%

Steps to Reproduce:
1. Create an rbd with storage class ocs-storagecluster-ceph-rbd and access mode rwx
2. Click Clone PVC in this pvc's actions menu
3. Click Clone on the confirmation modal


Actual results:

Cloning of the pvc fails


Expected results:

Pvc is cloned successfully

Comment 2 Elena Bondarenko 2020-08-26 11:14:34 UTC
Created attachment 1712671 [details]
Events log of rbd pvc's clone with the error

Comment 5 Elena Bondarenko 2020-09-21 11:53:37 UTC
I re-tested with 4.6.0-0.nightly-2020-09-21-030155, an rbd pvc with block volume mode was cloned successfully, the clone reached status Bound without any errors.

Comment 8 errata-xmlrpc 2020-10-27 16:31:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.