Bug 1871769 - [IPI baremetal] Keepalived.conf remember old ip's which are not available anymore
Summary: [IPI baremetal] Keepalived.conf remember old ip's which are not available any...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Yossi Boaron
QA Contact: Nataf Sharabi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-24 08:52 UTC by Nataf Sharabi
Modified: 2020-10-27 16:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Starting from OCP 4.6 Keepalived runs in unicast mode, which means the bootstrap IP address should be included in the Keepalived configuration of master nodes. After bootstrap VM removed the bootstrap IP address still included in masters Keepalived configuration. Consequence: In case the bootstrap IP address will be allocated by the DHCP server to some other machine, master nodes will spam this machine with unicast VRRP announcement packets. Fix: Change the Keepalived flow during bootstrap, so the bootstrap will own the VIP till bootstrap complete phase and then the Keepalived on the bootstrap node will be shut down by the keepalived-monitor container on bootstrap. With this approach, master nodes don't need to include the bootstrap IP address in their Keepalived configuration. Result: No unused IP addresses included in Keepalived configuration file on master nodes.
Clone Of:
Environment:
Last Closed: 2020-10-27 16:30:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 2107 0 None closed Bug 1871769: [baremetal] keep API VIP in the bootstrap node until the bootstrap’s node API goes away 2021-02-18 12:03:45 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:30:58 UTC

Description Nataf Sharabi 2020-08-24 08:52:59 UTC
Description of problem:

Due to unicast changes in configuration,
After installation we can the keepalived.conf holds the bootstrap ip,
Even though it is no longer available.



Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-08-18-165040

How reproducible:


Steps to Reproduce:
1.Deploy ocp 4.6.
2.On master node:
  cat /etc/keepalived/keepalived.conf

Actual results:


Expected results:
We should clean this old ip's that are no longer available.

Additional info:

Comment 1 Antoni Segura Puimedon 2020-08-25 14:57:51 UTC
Moving severity to low, since it does not affect the cluster.

Comment 2 Ben Nemec 2020-08-25 15:00:53 UTC
Targeting to 4.7 since this doesn't need to block 4.6. If we fix it before release we can always pull this back in.

Comment 3 Nataf Sharabi 2020-09-30 19:55:32 UTC
Verified on 
[kni@provisionhost-0-0 ~]$ oc version
Client Version: 4.6.0-fc.8
Server Version: 4.6.0-fc.8
Kubernetes Version: v1.19.0+359dd79

Comment 6 errata-xmlrpc 2020-10-27 16:30:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.