Bug 1871821 - [Assisted-4.5][Integration env] Cluster details page failed to load
Summary: [Assisted-4.5][Integration env] Cluster details page failed to load
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: assisted-installer
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.6.0
Assignee: Rastislav Wagner
QA Contact: Udi Kalifon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-24 11:21 UTC by Lital Alon
Modified: 2020-10-27 16:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:30:45 UTC
Target Upstream Version:


Attachments (Terms of Use)
Cluster details page load failure (106.72 KB, image/png)
2020-08-24 11:21 UTC, Lital Alon
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github mareklibra facet-lib pull 163 0 None closed Bug 1871821: Fix possible loop in host subnets 2020-10-09 06:56:31 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:30:58 UTC

Description Lital Alon 2020-08-24 11:21:11 UTC
Created attachment 1712339 [details]
Cluster details page load failure

Created attachment 1712339 [details]
Cluster details page load failure

Created attachment 1712339 [details]
Cluster details page load failure

Created attachment 1712339 [details]
Cluster details page load failure

Created attachment 1712339 [details]
Cluster details page load failure

Description of problem:
After playing a bit with the Cluster details page (ran cluster and host validation tests), got to a stage where cluster details page cannot be loaded, and displays an error (see attached)



How reproducible:
Integration environment
Using QE user (nshidlin-aiqe1)

Steps to Reproduce:
1. boot 2 masters belong to CIDR-A and one master belong to CIDR-B. wait until they discovered
2. mark all role nodes to master
3. fill in all cluster parameters. In the Available Subnets put CIDR-B along with Ingress VIP and API VIP. Save changes.
4. Kill master node that belongs to CIDR-B
5. from console, choose to disable the node
6. from console, choose to enable the master node again

Actual results:
Page load error

Expected results:
Page should load

Additional info:
Ran Cluster and Hosts validation tests when reproduced. Mostly connected agents, and play with hosts interfaces, hostnames, subnet CIDR, enable/disable hosts and so. The only reproduce able scenario i could catch described above.

Comment 1 Lital Alon 2020-08-24 11:21:46 UTC
UI ERROR:

Danger alert:Something went wrong
Error: Minified React error #301; visit https://reactjs.org/docs/error-decoder.html?invariant=301 for the full message or use the non-minified dev environment for full errors and additional helpful warnings.
    in le
    in ta
    in na
    in mn
    in Za
    in t
    in t
    in to
    in u
    in eo
    in Unknown
    in x
    in t
    in t
    in t
    in n
    in r
    in x
    in o1
    in withRouter(o1)
    in s1
    in d1
    in x
    in t
    in t
    in u

Comment 2 Lital Alon 2020-09-01 12:47:17 UTC
Verified in Staging (deployed at: Sep, 1)

Comment 5 errata-xmlrpc 2020-10-27 16:30:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.