Bug 1871832 - APIServerServiceUnavailableErrorjava error makes ImageChangesInProgress keeping true that blocked the upgrade processed
Summary: APIServerServiceUnavailableErrorjava error makes ImageChangesInProgress keepi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Samples
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.z
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
: 1872371 (view as bug list)
Depends On: 1857201
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-24 11:59 UTC by OpenShift BugZilla Robot
Modified: 2020-09-22 06:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: intermittent API server errors were reported on the wrong condition (ImageChangesInProgress instead of SamplesExists) of the cluster operator config object. Consequence: when API server communication returned and all the samples were installed, the samples operator would fail to switch Progressing to false because there was unexpected data in its ImageChangesInProgress condition, and upgrades would incorrectly be marked as incomplete. Fix: code change was made to update SamplesExists with error reports on APIServer communication Result: upgrades are no longer blocked if intermittent APIServer errors occur while samples operator is upgrading.
Clone Of:
Environment:
Last Closed: 2020-09-22 06:58:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-samples-operator pull 315 None closed [release-4.4] Bug 1871832: initial create errors should map to SamplesExists instead of ImageChangesInProgress 2020-09-21 11:52:25 UTC
Red Hat Product Errata RHBA-2020:3715 None None None 2020-09-22 06:59:00 UTC

Comment 1 Gabe Montero 2020-08-26 14:19:13 UTC
*** Bug 1872371 has been marked as a duplicate of this bug. ***

Comment 3 Gabe Montero 2020-09-01 12:50:52 UTC
@Abhishek

The customer can run

oc delete configs.samples cluster

That should clear out the samples operator and have it retry.  Assuming the api server is fully accessible samples should come up OK.

Comment 4 Adam Kaplan 2020-09-10 14:34:45 UTC
PR is LGTM and is awaiting patch manager approval.

Comment 6 XiuJuan Wang 2020-09-14 03:39:26 UTC
Delete apiserver pods during samples operator removing or creating imagestream, the APISERVER error reports in samplesexist part.
 
   - lastTransitionTime: "2020-09-14T03:36:11Z"
      lastUpdateTime: "2020-09-14T03:36:11Z"
      message: The error the server is currently unable to handle the request (get
        imagestreams.image.openshift.io) during openshift namespace cleanup has left
        the samples in an unknown state
      reason: APIServerServiceUnavailableError
      status: Unknown
      type: SamplesExist

Verified on 4.4.0-0.nightly-2020-09-12-143345 cluster

Comment 9 errata-xmlrpc 2020-09-22 06:58:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.4.23 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3715


Note You need to log in before you can comment on or make changes to this bug.