Bug 187185 - all sleep modes should be available
all sleep modes should be available
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-28 20:42 EST by Andre Robatino
Modified: 2013-03-13 00:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-17 15:44:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2006-03-28 20:42:45 EST
Description of problem:
  gnome-power-manager doesn't make available all sleep modes.  For example, my
BIOS gives a choice of suspend being either S1 or S3.  If I select S3, "suspend"
is one of the options in the GUI.  However, if I select S1, nothing
corresponding appears.  On my box, S1 works properly while S3 does not.  It
would be nice if ALL available sleep modes were available.  To avoid ambiguity,
each level should have the sleep number next to it, for example

Do nothing (S0)
Sleep (S1)
Suspend (S3)
Hibernate (S4)
Power off (S5)

It would also be nice if each sleep mode other than S0 appeared in the System
menu under "Log Out <user>...", labeled in the same way.


Version-Release number of selected component (if applicable):
gnome-power-manager-2.14.0-1
Comment 1 Richard Hughes 2006-03-29 02:28:50 EST
gnome-power-manager only allows what HAL thinks we can do. If you boot with
either option selected, and then do:

lshal | grep can_suspend

You'll see why this happens. For what it's worth, hal never supported sleep,
just suspend, hibernate and shutdown.

This is likely a HAL problem.
Comment 2 Andre Robatino 2006-03-29 17:10:06 EST
  I've changed the component to HAL, and also changed the bug description to be
agnostic as to where the problem is coming from.  The output of "lshal | grep
can_suspend" (with standby mode in BIOS set to S1) is

power_management.can_suspend_to_disk = true  (bool)
power_management.can_suspend_to_ram = false  (bool)

Do you know if the reason the lower sleep modes aren't supported is because they
aren't considered worthy of support (maybe they were originally introduced to
make it easier for the OS to support them)?
  I also noticed that "Hibernate" is not listed as an option in the System menu,
even though it's available.
Comment 3 Richard Hughes 2006-03-30 02:28:17 EST
Do "cat /sys/power/state" : if mem is listed, your machine can do suspend to
memory. If disk is listed, you get suspend to disk. Also, is /proc/suspend2 is
listed you also get suspend to disk. SO HAL is really only copying what the
kernel is telling us. Does that help?
Comment 4 John (J5) Palmieri 2006-04-17 15:33:11 EDT
I would say no on this.  If S3 or hibernate doesn't work we need to fix it for
your laptop (one of the fedora lists and the fedora wiki would be a good start).
 Exposing S modes (or even just more modes) to the user is wrong.  If you are a
power user you can figure out how to modify the pm scripts to bandaid your
system (or you can ask for help on fixing the real issues which is more useful
for other users of your hardware).     
Comment 5 Richard Hughes 2006-04-17 15:44:58 EDT
Yes, agreed.
Comment 6 Andre Robatino 2006-04-18 00:10:17 EDT
  It's actually a desktop.  AFAIK, everything looks normal when it goes into S3
suspend, but when I wake it up, it's unaware that it was suspended, and it has
to clean up a few orphan inodes.  Is it at all possible that it could be
deficient hardware?  (The BIOS gives a choice of either S1 or S3 for RAM
suspend, with S1 the default.)  And if it's the OS, which component should I
report it under?
  Strangely, hibernation seems to work.

Note You need to log in before you can comment on or make changes to this bug.