Bug 187190 - Pirut, yumex fail at "import gtk"
Pirut, yumex fail at "import gtk"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pygtk2 (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-28 21:34 EST by Michael Breuer
Modified: 2013-03-13 00:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-17 15:38:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Breuer 2006-03-28 21:34:36 EST
Description of problem:

yumex and pirut fail at "import gtk"

Version-Release number of selected component (if applicable):


How reproducible:

Always (for me).  See additional info.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

This system was upgraded via CD from fc4.  Following the upgrade, pirut failed
at, "import glx."  I installed yumex as an alternative and go the same results
(with some more detail):

[root@mail lib]# yumex
Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 24, in ?
    import gtk
  File "/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 38, in ?
   from _gtk import *
ImportError: /usr/lib/libcairo.so.2: undefined symbol: FT_GlyphSlot_Embolden

Note: I've updated everything (yum update) - I also tried uninstalling and
re-installing many things - all to no avail.  I found several websites reporting
similar issues, none of the stated solutions worked. 

I'm guessing that some dependency wasn't installed.  Perhaps there was something
lying around from fc4 which compromised the upgrade.  Please let me know what
additional information I can provide.

Thanks.
Comment 1 Dawid Zamirski 2006-03-30 13:46:44 EST
You probably have some packages not installed broken. First you should check
yuor package versions:

[maners@athlon64 ~]$ rpm -qa | grep pygtk
pygtk2-libglade-2.8.4-1.1
pygtk2-2.8.4-1.1
pygtk2-devel-2.8.4-1.1
[maners@athlon64 ~]$ rpm -q gtk2
gtk2-2.8.15-1
[maners@athlon64 ~]$ rpm -q cairo
cairo-1.0.4-1

If some version doesn't match you should try to yum update it. Otherwise try
uninstall and then install again those packages and look for any scriptlet
errors etc.
Comment 2 Michael Breuer 2006-03-31 10:01:56 EST
All packages were present.  I uninstalled and re-installed.  Following is the
only error I could see:

Running Transaction
  Installing: cairo                        ######################### [1/4]
  Installing: gtk2                         ######################### [2/4]
g_module_open() failed for /usr/lib/gtk-2.0/2.4.0/loaders/svg_loader.so: /usr/li
b/libcairo.so.2: undefined symbol: FT_GlyphSlot_Embolden
[snip]
Comment 3 Dawid Zamirski 2006-03-31 12:14:35 EST
I found something related on google:
http://clunixchit.blogspot.com/2005/10/fc4-gtk-python-issue.html

the svg_loader.so file comes from librsvg2 package. In FC5 its version should be
2.14.2-1. According to the various google results ( eg.
http://www.fedoraforum.org/forum/archive/index.php/t-59407.html ) the error
comes from freetype. 
My verions are as the following:
[root@athlon64 maners]# rpm -qa | grep freetype
freetype-2.1.10-5.2.1
freetype-devel-2.1.10-5.2.1
freetype-2.1.10-5.2.1

Comment 4 Michael Breuer 2006-03-31 12:48:22 EST
Ok - I think I found something... it'll take awile to fix it carefully (so as
not to have to re-install everything).

It looks like the upgrade-install left old freetype libraries in /usr/X11R6/lib.
 There is actually quite a bit of debris there... libraries last modified in
2003 not owned by any package.  I'm going to clean up the directory & re-install
everything which does have an "owned" package there.

If this is the case, then this report should be re-directed at the installer for
FC5 (and others?) for not cleaning up well.  Then again, this could have been
left over from other upgrades but just manifest now.
Comment 5 Michael Breuer 2006-03-31 18:44:41 EST
Yes - that was it.

The issue is now resolved (for me), but the upgrade process should probably be
enhanced to clean up /usr/X11R6/lib.

Note You need to log in before you can comment on or make changes to this bug.