Bug 187195 - snort-mysql package is built without database mysql support
Summary: snort-mysql package is built without database mysql support
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: snort   
(Show other bugs)
Version: 3
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-29 04:18 UTC by Techwolf
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 04:55:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Techwolf 2006-03-29 04:18:49 UTC
Snort-mysql on fc3 x86_64 is built without mysql support, resulting in failure
to startup with error saying "database: 'mysql' support is not compiled into
this build of snort". Also, the /usr/sbin/snort-plain and /usr/sbin/snort-mysql
only differ by 32 bytes in size.

Comment 1 Techwolf 2006-03-29 05:12:16 UTC
Found the problem and the fix. Turns out the make system is not picking up all
the ./configure changes and therefore not re-building the plugins with the
changes. The soluction was to add a "make clean" after each build in the spec file.

Comment 2 Michael Rozman 2006-03-29 23:36:47 UTC
I can confirm that the same bug is present in FC5 snort-mysql from fedora-extras
and that the suggested fix works for FC5.  


Note You need to log in before you can comment on or make changes to this bug.