Bug 1871951 - [sig-arch] Managed cluster should ensure control plane pods do not run in best-effort QoS
Summary: [sig-arch] Managed cluster should ensure control plane pods do not run in bes...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.z
Assignee: Seth Jennings
QA Contact: Sunil Choudhary
URL:
Whiteboard:
: 1871293 (view as bug list)
Depends On: 1860157
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-24 16:41 UTC by Antonio Ojea
Modified: 2020-09-08 10:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
[sig-arch] Managed cluster should ensure control plane pods do not run in best-effort QoS
Last Closed: 2020-09-08 10:54:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 25316 None closed Bug 1871951: allow recycler pods to run with best effort qos 2020-09-23 17:04:51 UTC
Red Hat Product Errata RHBA-2020:3510 None None None 2020-09-08 10:55:26 UTC

Description Antonio Ojea 2020-08-24 16:41:00 UTC
test:
[sig-arch] Managed cluster should ensure control plane pods do not run in best-effort QoS 

is failing frequently in CI, see search results:
https://search.ci.openshift.org/?maxAge=168h&context=1&type=bug%2Bjunit&name=&maxMatches=5&maxBytes=20971520&groupBy=job&search=%5C%5Bsig-arch%5C%5D+Managed+cluster+should+ensure+control+plane+pods+do+not+run+in+best-effort+QoS

With the following query

https://search.ci.openshift.org/?search=%5C%5Bsig-arch%5C%5D+Managed+cluster+should+ensure+control+plane+pods+do+not+run+in+best-effort+QoS&maxAge=168h&context=5&type=bug%2Bjunit&name=4.5&maxMatches=5&maxBytes=20971520&groupBy=job

we can see better the error

# [sig-arch] Managed cluster should ensure control plane pods do not run in best-effort QoS [Suite:openshift/conformance/parallel]
fail [github.com/openshift/origin/test/extended/operators/qos.go:51]: Aug 20 02:56:33.477:
1 pods found in best-effort QoS:
openshift-infra/recycler-for-nfs-f6lfz is running in best-effort QoS

Comment 1 Seth Jennings 2020-08-25 18:40:29 UTC
https://github.com/openshift/origin/pull/25315 fixed this on master.

Needs backport to 4.5

https://github.com/openshift/origin/pull/25316

Comment 6 Fabio Bertinatto 2020-09-03 12:11:55 UTC
*** Bug 1871293 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2020-09-08 10:54:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.8 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3510


Note You need to log in before you can comment on or make changes to this bug.