Bug 187201 - system-config.lvm crash with BlockDevice.BlockDeviceErr_cannotFit: <BlockDevice.BlockDeviceErr_cannotFit instance at 0xb7b5460c>
system-config.lvm crash with BlockDevice.BlockDeviceErr_cannotFit: <BlockDevi...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-lvm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Jim Parsons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-29 00:33 EST by Knut J BJuland
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-20 01:09:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace off a system-config runf. (190.46 KB, application/octet-stream)
2006-06-14 04:54 EDT, Knut J BJuland
no flags Details

  None (edit)
Description Knut J BJuland 2006-03-29 00:33:25 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Reproducible each time.

Steps to Reproduce:
1. system-config-lvm
2.
3.
  
Actual results:
Traceback (most recent call last):
  File "/usr/share/system-config-lvm/system-config-lvm.py", line 138, in ?
    runFullGUI()
  File "/usr/share/system-config-lvm/system-config-lvm.py", line 123, in runFullGUI
    blvm = baselvm(glade_xml, app)
  File "/usr/share/system-config-lvm/system-config-lvm.py", line 68, in __init__
   self.lvmm = lvm_model()
  File "/usr/share/system-config-lvm/lvm_model.py", line 142, in __init__
    self.__block_device_model = BlockDeviceModel()
  File "/usr/share/system-config-lvm/BlockDeviceModel.py", line 19, in __init__
    bd = BlockDevice(devname)
  File "/usr/share/system-config-lvm/BlockDevice.py", line 41, in __init__
    self.reload()
  File "/usr/share/system-config-lvm/BlockDevice.py", line 62, in reload
    self.addNoAlign(part.beg, part.end, part.id, part.bootable, part.num)
  File "/usr/share/system-config-lvm/BlockDevice.py", line 213, in addNoAlign
    self.__insert(part)
  File "/usr/share/system-config-lvm/BlockDevice.py", line 218, in __insert
    self.__insert2(part, self.__segs, False)
  File "/usr/share/system-config-lvm/BlockDevice.py", line 248, in __insert2
    raise BlockDeviceErr_cannotFit()
BlockDevice.BlockDeviceErr_cannotFit: <BlockDevice.BlockDeviceErr_cannotFit
instance at 0xb7b5460c>



Expected results:

I should be able to use system-config-lvm

Additional info:

Standard lvm system setup by Fedora 4 anacona setup.
Comment 1 Erik Jacobson 2006-03-29 12:12:33 EST
I'm seeing this as well.  I let the installer set up the volume with defaults
(initial/fresh install).

In my case, the lvm volume sits on top of bios-assisted-software-raid
(nforce4, dual-sata, striped) that was properly found by the installer and
I left defaults.  I'm crashing with the same traceback.
Comment 2 Jim Parsons 2006-03-29 12:15:32 EST
Ouch. Aggressively investigating...thanks for the notice.
Comment 3 Robert Mortimer 2006-04-18 10:08:50 EDT
I have the same problem on a rocket raid card (2xSATA striped) the dev mapper is
now great and the install is a lot better than FC3 or 4 but system-config-lvm
does not work.
Comment 4 Knut J BJuland 2006-05-01 16:38:59 EDT
System-config-lvm-1.0.16-1.0 from enterprise is also affected by this bug. I
compiled the srpm on a Fedora 5 system.

Traceback (most recent call last):
  File "/usr/share/system-config-lvm/system-config-lvm.py", line 138, in ?
    runFullGUI()
  File "/usr/share/system-config-lvm/system-config-lvm.py", line 123, in runFullGUI
    blvm = baselvm(glade_xml, app)
  File "/usr/share/system-config-lvm/system-config-lvm.py", line 68, in __init__
    self.lvmm = lvm_model()
  File "/usr/share/system-config-lvm/lvm_model.py", line 142, in __init__
    self.__block_device_model = BlockDeviceModel()
  File "/usr/share/system-config-lvm/BlockDeviceModel.py", line 19, in __init__
    bd = BlockDevice(devname)
  File "/usr/share/system-config-lvm/BlockDevice.py", line 41, in __init__
    self.reload()
  File "/usr/share/system-config-lvm/BlockDevice.py", line 62, in reload
    self.addNoAlign(part.beg, part.end, part.id, part.bootable, part.num)
  File "/usr/share/system-config-lvm/BlockDevice.py", line 206, in addNoAlign
    self.__insert(part)
  File "/usr/share/system-config-lvm/BlockDevice.py", line 211, in __insert
    self.__insert2(part, self.__segs, False)
  File "/usr/share/system-config-lvm/BlockDevice.py", line 241, in __insert2
    raise BlockDeviceErr_cannotFit()
BlockDevice.BlockDeviceErr_cannotFit: <BlockDevice.BlockDeviceErr_cannotFit
instance at 0xb7b1560c>

 pvdisplay
  --- Physical volume ---
  PV Name               /dev/sda6
  VG Name               VolGroup00
  PV Size               130.78 GB / not usable 0
  Allocatable           yes
  PE Size (KByte)       32768
  Total PE              4185
  Free PE               2
  Allocated PE          4183
  PV UUID               4HjA5g-6BO0-IXIO-tLTD-Bhrn-Klz8-mn510W

  --- Physical volume ---
  PV Name               /dev/sdb3
  VG Name               VolGroup00
  PV Size               228.81 GB / not usable 0
  Allocatable           yes (but full)
  PE Size (KByte)       32768
  Total PE              7322
  Free PE               0
  Allocated PE          7322
  PV UUID               VMNObX-eq5b-Poj1-3r54-sePx-1Btq-MmXq6D

 vgdisplay
  --- Volume group ---
  VG Name               VolGroup00
  System ID
  Format                lvm2
  Metadata Areas        2
  Metadata Sequence No  5
  VG Access             read/write
  VG Status             resizable
  MAX LV                0
  Cur LV                2
  Open LV               2
  Max PV                0
  Cur PV                2
  Act PV                2
  VG Size               359.59 GB
  PE Size               32.00 MB
  Total PE              11507
  Alloc PE / Size       11505 / 359.53 GB
  Free  PE / Size       2 / 64.00 MB
  VG UUID               6ltOn2-wBLt-PCmT-g0fa-23GI-B6qq-LOejKG

Comment 5 Stanko Kupcevic 2006-05-11 17:29:55 EDT
Could you post the output of 'sfdisk -l -uS <devname>' for all hard drives.



Comment 6 Knut J BJuland 2006-05-12 12:44:49 EDT
sfdisk -l uS /dev/sda

Disk /dev/sda: 19452 cylinders, 255 heads, 63 sectors/track
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sda1            63    128519     128457  de  Dell Utility
/dev/sda2   *    128520  30635954   30507435   7  HPFS/NTFS
/dev/sda3     305154675 312496379    7341705  db  CP/M / CTOS / ...
/dev/sda4      30635955 305154674  274518720   5  Extended
/dev/sda5      30636018  30844799     208782  83  Linux
/dev/sda6      30844863 305154674  274309812  8e  Linux LVM

[knutjbj@knutjorgen ~]$ sfdisk -l -uS /dev/sdb

Disk /dev/sdb: 30401 cylinders, 255 heads, 63 sectors/track
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sdb1            63    289169     289107  83  Linux
/dev/sdb2        289170   8482319    8193150  82  Linux swap / Solaris
/dev/sdb3       8482320 488392064  479909745  8e  Linux LVM
/dev/sdb4             0         -          0   0  Empty

Comment 7 Stanko Kupcevic 2006-05-12 17:21:05 EDT
Hm, that should work fine; are there more hard drives? 
Can you post the result of `blockdev --report` please? 
Comment 8 Knut J BJuland 2006-05-12 20:40:12 EDT
rw   256   512  4096          0  312500000  /dev/sda
rw   256   512   512         63     128457  /dev/sda1
rw   256   512   512     128520   30507435  /dev/sda2
rw   256   512   512  305154675    7341705  /dev/sda3
rw   256   512  1024   30635955          2  /dev/sda4
rw   256   512  1024   30636018     208782  /dev/sda5
rw   256   512  2048   30844863  274309812  /dev/sda6
rw   256   512  4096          0  488397168  /dev/sdb
rw   256   512   512         63     289107  /dev/sdb1
rw   256   512  4096     289170    8193150  /dev/sdb2
rw   256   512   512    8482320  479909745  /dev/sdb3
rw   256   512  4096          0     251904  /dev/sdc
rw   256   512   512         32     251904  /dev/sdc1
rw   256   512  4096          0    1010784  /dev/sdd
rw   256   512   512         32    1010751  /dev/sdd1
rw   256   512  4096          0  160836480  /dev/sde
rw   256   512   512         63  160810587  /dev/sde1
Comment 9 Knut J BJuland 2006-05-12 21:04:30 EDT
Disk /dev/sdb: 30401 cylinders, 255 heads, 63 sectors/track
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sdb1            63    289169     289107  83  Linux
/dev/sdb2        289170   8482319    8193150  82  Linux swap / Solaris
/dev/sdb3       8482320 488392064  479909745  8e  Linux LVM
/dev/sdb4             0         -          0   0  Empty

Disk /dev/sdc: 1015 cylinders, 4 heads, 62 sectors/track
Warning: The partition table looks like it was made
  for C/H/S=*/32/32 (instead of 1015/4/62).
For this listing I'll assume that geometry.
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sdc1   *        32    251935     251904   6  FAT16
                end: (c,h,s) expected (246,0,32) found (245,31,32)
/dev/sdc2             0         -          0   0  Empty
/dev/sdc3             0         -          0   0  Empty
/dev/sdc4             0         -          0   0  Empty

Disk /dev/sdd: 1018 cylinders, 16 heads, 62 sectors/track
Warning: The partition table looks like it was made
  for C/H/S=*/128/32 (instead of 1018/16/62).
For this listing I'll assume that geometry.
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sdd1   *        32   1010782    1010751   4  FAT16 <32M
                end: (c,h,s) expected (246,98,31) found (249,127,32)
/dev/sdd2             0         -          0   0  Empty
/dev/sdd3             0         -          0   0  Empty
/dev/sdd4             0         -          0   0  Empty

Disk /dev/sde: 10011 cylinders, 255 heads, 63 sectors/track
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sde1            63 160810649  160810587   c  W95 FAT32 (LBA)
                end: (c,h,s) expected (1023,254,63) found (793,254,63)
/dev/sde2             0         -          0   0  Empty
/dev/sde3             0         -          0   0  Empty
/dev/sde4             0         -          0   0  Empty
[knutjbj@knutjorgen ~]$ sfdisk -l -uS sde
sde: No such file or directory

sfdisk: cannot open sde for reading
[knutjbj@knutjorgen ~]$ sfdisk -l -uS /dev/sde

Disk /dev/sde: 10011 cylinders, 255 heads, 63 sectors/track
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sde1            63 160810649  160810587   c  W95 FAT32 (LBA)
                end: (c,h,s) expected (1023,254,63) found (793,254,63)
/dev/sde2             0         -          0   0  Empty
/dev/sde3             0         -          0   0  Empty
/dev/sde4             0         -          0   0  Empty
[knutjbj@knutjorgen ~]$ sfdisk -l -u /dev/sde
unrecognized format - using sectors

Disk /dev/sda: 19452 cylinders, 255 heads, 63 sectors/track
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sda1            63    128519     128457  de  Dell Utility
/dev/sda2   *    128520  30635954   30507435   7  HPFS/NTFS
/dev/sda3     305154675 312496379    7341705  db  CP/M / CTOS / ...
/dev/sda4      30635955 305154674  274518720   5  Extended
/dev/sda5      30636018  30844799     208782  83  Linux
/dev/sda6      30844863 305154674  274309812  8e  Linux LVM

Disk /dev/sdb: 30401 cylinders, 255 heads, 63 sectors/track
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sdb1            63    289169     289107  83  Linux
/dev/sdb2        289170   8482319    8193150  82  Linux swap / Solaris
/dev/sdb3       8482320 488392064  479909745  8e  Linux LVM
/dev/sdb4             0         -          0   0  Empty

Disk /dev/sdc: 1015 cylinders, 4 heads, 62 sectors/track
Warning: The partition table looks like it was made
  for C/H/S=*/32/32 (instead of 1015/4/62).
For this listing I'll assume that geometry.
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sdc1   *        32    251935     251904   6  FAT16
                end: (c,h,s) expected (246,0,32) found (245,31,32)
/dev/sdc2             0         -          0   0  Empty
/dev/sdc3             0         -          0   0  Empty
/dev/sdc4             0         -          0   0  Empty

Disk /dev/sdd: 1018 cylinders, 16 heads, 62 sectors/track
Warning: The partition table looks like it was made
  for C/H/S=*/128/32 (instead of 1018/16/62).
For this listing I'll assume that geometry.
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sdd1   *        32   1010782    1010751   4  FAT16 <32M
                end: (c,h,s) expected (246,98,31) found (249,127,32)
/dev/sdd2             0         -          0   0  Empty
/dev/sdd3             0         -          0   0  Empty
/dev/sdd4             0         -          0   0  Empty

Disk /dev/sde: 10011 cylinders, 255 heads, 63 sectors/track
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sde1            63 160810649  160810587   c  W95 FAT32 (LBA)
                end: (c,h,s) expected (1023,254,63) found (793,254,63)
/dev/sde2             0         -          0   0  Empty
/dev/sde3             0         -          0   0  Empty
/dev/sde4             0         -          0   0  Empty
Comment 10 Knut J BJuland 2006-06-14 04:49:51 EDT
The error is still present in system-config-lvm-1.0.13-2. I have made an strace
log off starting system-config.lvm. It works vith evms-gui.
Comment 11 Knut J BJuland 2006-06-14 04:54:18 EDT
Created attachment 130809 [details]
strace off a system-config runf.

Fedora Fc5 with all update none rawhide rpm packages.
Comment 12 Knut J BJuland 2006-06-20 01:09:17 EDT
This bug is fixed in system-config-lvm-1.0.18-1.2.FC6

Note You need to log in before you can comment on or make changes to this bug.