Bug 187209 - rpc.svcgssd segfaults
Summary: rpc.svcgssd segfaults
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-utils-lib   
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-29 08:27 UTC by Kostas Georgiou
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 23:29:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kostas Georgiou 2006-03-29 08:27:19 UTC
After the update to FC5 (rawhide was fine) rpc.svcgssd dies at random times with
the following error (taken with OPTIONS="-v -r" in the init script):

rpc.svcgssd[13785]: leaving poll
rpc.svcgssd[13785]: handling null request
rpc.svcgssd[13785]:
rpc.svcgssd[13785]: sname = nfs/foo.domain@DOMAIN
kernel: rpc.svcgssd[13785]: segfault at 0000000000000000 rip 00002b55a8a76160
rsp 00007fffffcfd328 error 4

Comment 1 Kostas Georgiou 2006-03-30 22:46:07 UTC
It looks like nscd is causing it, here is the stack trace (no debuginfo yet
though, sorry). 

#0  0x00002aaaab865160 in strlen () from /lib64/libc.so.6
#1  0x00002aaaab8ec988 in __nscd_getgrouplist () from /lib64/libc.so.6
#2  0x00002aaaab8814e4 in internal_getgrouplist () from /lib64/libc.so.6
#3  0x00002aaaab881703 in getgrouplist () from /lib64/libc.so.6
#4  0x00002aaaaaddd19b in nss_gss_princ_to_grouplist () from
/usr/lib64/libnfsidmap.so.0
#5  0x0000555555557461 in main () from /usr/sbin/rpc.svcgssd

Disabling nscd cured the problem in both my servers.

Comment 2 Kostas Georgiou 2006-03-30 23:03:12 UTC
Here is the output with glibc-debuginfo installed. 
Should I reassign the bug to glibc?

(gdb) where
#0  0x00002aaaab865160 in ?? () from /lib64/libc.so.6
#1  0x00002aaaab8ec988 in __nscd_getgrouplist (user=0x0, group=0,
size=0x7fffffa0a7c0,
    groupsp=0x7fffffa0a7c8, limit=Variable "limit" is not available.
) at nscd_initgroups.c:40
#2  0x00002aaaab8814e4 in internal_getgrouplist (user=0x0, group=0,
size=0x7fffffa0a7c0,
    groupsp=0x7fffffa0a7c8, limit=-1) at initgroups.c:60
#3  0x00002aaaab881703 in getgrouplist (user=0x0, group=0, groups=0x7fffffa0a89c,
    ngroups=0x7fffffa0a898) at initgroups.c:158
#4  0x00002aaaaaddd19b in nss_gss_princ_to_grouplist () from
/usr/lib64/libnfsidmap.so.0
#5  0x0000555555557461 in main () from /usr/sbin/rpc.svcgssd


Comment 3 Kostas Georgiou 2006-03-30 23:29:03 UTC
Aha http://linux-nfs.org/pipermail/nfsv4/2006-March/003775.html

Reassigning to nfs-utils-lib.  


Note You need to log in before you can comment on or make changes to this bug.