Bug 1872176 - There is no yaml file https://github.com/operator-framework/operator-lifecycle-manager/releases/download/0.16.0/crds.yaml
Summary: There is no yaml file https://github.com/operator-framework/operator-lifecycl...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Alexander Greene
QA Contact: yhui
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-25 08:33 UTC by yhui
Modified: 2020-10-27 16:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:33:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:33:04 UTC

Description yhui 2020-08-25 08:33:50 UTC
Description of problem:
Met an error during executing the commands "operator-sdk olm status --olm-namespace openshift-operator-lifecycle-manager" since there is no yaml file https://github.com/operator-framework/operator-lifecycle-manager/releases/download/0.16.0/crds.yaml.

[root@preserve-olm-env memcached-operator]# operator-sdk olm status --olm-namespace openshift-operator-lifecycle-manager
I0825 04:12:26.394054   14018 request.go:621] Throttling request took 1.027917971s, request: GET:https://api.kuiwang20200825t070000.qe.devcluster.openshift.com:6443/apis/machineconfiguration.openshift.io/v1?timeout=32s
INFO[0002] Fetching CRDs for version "0.16.0"           
FATA[0002] Failed to get OLM status: failed to get resources: failed to fetch CRDs: request failed: failed GET 'https://github.com/operator-framework/operator-lifecycle-manager/releases/download/0.16.0/crds.yaml': unexpected status code 404, expected 200: Not Found


Version-Release number of selected component (if applicable):
OCP: 4.6.0
[root@preserve-olm-env memcached-operator]# oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-08-23-185640   True        False         8h      Cluster version is 4.6.0-0.nightly-2020-08-23-185640
OLM: 0.16.0
[root@preserve-olm-env memcached-operator]# oc exec olm-operator-7656fb58d4-xmn6n -n openshift-operator-lifecycle-manager -- olm --version
OLM version: 0.16.0
git commit: c3852d57c86707deb80c042c2155ad82c2d9628f
operator-sdk: v1.0.0
[root@preserve-olm-env memcached-operator]# operator-sdk version
operator-sdk version: "v1.0.0-37-g01df5b3", commit: "01df5b3ba66cb6fe3ba0feb21367f87653ef5716", kubernetes version: "v1.18.2", go version: "go1.14 linux/amd64", GOOS: "linux", GOARCH: "amd64"

How reproducible:
Always

Steps to Reproduce:
1. Install OCP 4.6.0 cluster and install the tool operator-sdk

2. Login to the cluster
[root@preserve-olm-env memcached-operator]# oc login https://api.kuiwang20200825t070000.qe.devcluster.openshift.com:6443
Authentication required for https://api.kuiwang20200825t070000.qe.devcluster.openshift.com:6443 (openshift)
Username: kubeadmin
Password: 
Login successful.

3. Execute the command.
[root@preserve-olm-env memcached-operator]# operator-sdk olm status --olm-namespace openshift-operator-lifecycle-manager
I0825 04:12:26.394054   14018 request.go:621] Throttling request took 1.027917971s, request: GET:https://api.kuiwang20200825t070000.qe.devcluster.openshift.com:6443/apis/machineconfiguration.openshift.io/v1?timeout=32s
INFO[0002] Fetching CRDs for version "0.16.0"           
FATA[0002] Failed to get OLM status: failed to get resources: failed to fetch CRDs: request failed: failed GET 'https://github.com/operator-framework/operator-lifecycle-manager/releases/download/0.16.0/crds.yaml': unexpected status code 404, expected 200: Not Found

There is an error since the 0.16.0 crds.yaml file cannot be found in the operator-lifecycle-manager git repo.

Check the git repo https://github.com/operator-framework/operator-lifecycle-manager. There are only zip and tar.gz package. No crds.yaml.

Actual results:
There is an error since failed GET 'https://github.com/operator-framework/operator-lifecycle-manager/releases/download/0.16.0/crds.yaml'


Expected results:
Executed successfully.


Additional info:

Comment 2 Alexander Greene 2020-09-08 14:28:30 UTC
I released version 0.16.1 of OLM with the expected payload. OLM's release process requires multiple commits, shown here:

* https://github.com/operator-framework/operator-lifecycle-manager/pull/1749
* https://github.com/operator-framework/operator-lifecycle-manager/pull/1750
* https://github.com/operator-framework/operator-lifecycle-manager/pull/1751

Please attempt to install OLM using the new release instead of 0.16.0.

Comment 5 yhui 2020-09-10 06:23:54 UTC
Version:
[hui@localhost verification-tests]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-09-09-184544   True        False         90m     Cluster version is 4.6.0-0.nightly-2020-09-09-184544
[hui@localhost verification-tests]$ oc exec catalog-operator-797df9898d-tlvhn -n openshift-operator-lifecycle-manager -- olm --version
OLM version: 0.16.1
git commit: 18dd8b36f2ca9d4778cedb5b4ec166c0ff886ece


Steps to test:
1. Install OCP 4.6 cluster and install the tool operator-sdk

2. Login to the cluster
[root@preserve-olm-env memcached-operator]# oc login https://api.xiyuan09101.qe.azure.devcluster.openshift.com:6443
Authentication required for https://api.xiyuan09101.qe.azure.devcluster.openshift.com:6443 (openshift)
Username: kubeadmin
Password: 
Login successful.

3. Execute the command.
[root@preserve-olm-env memcached-operator]# operator-sdk olm status --olm-namespace openshift-operator-lifecycle-manager
I0910 02:11:53.362181   12272 request.go:621] Throttling request took 1.019020686s, request: GET:https://api.xiyuan09101.qe.azure.devcluster.openshift.com:6443/apis/snapshot.storage.k8s.io/v1beta1?timeout=32s
INFO[0002] Fetching CRDs for version "0.16.1"           
INFO[0002] Fetching resources for version "0.16.1"      
INFO[0003] Successfully got OLM status for version "0.16.1" 

NAME                                            NAMESPACE    KIND                        STATUS
operators.operators.coreos.com                               CustomResourceDefinition    Installed
operatorgroups.operators.coreos.com                          CustomResourceDefinition    Installed
installplans.operators.coreos.com                            CustomResourceDefinition    Installed
clusterserviceversions.operators.coreos.com                  CustomResourceDefinition    Installed
subscriptions.operators.coreos.com                           CustomResourceDefinition    Installed
system:controller:operator-lifecycle-manager                 ClusterRole                 Installed
aggregate-olm-edit                                           ClusterRole                 Installed
aggregate-olm-view                                           ClusterRole                 Installed
catalogsources.operators.coreos.com                          CustomResourceDefinition    Installed
olm                                                          Namespace                   namespaces "olm" not found
olm-operator-binding-olm                                     ClusterRoleBinding          clusterrolebindings.rbac.authorization.k8s.io "olm-operator-binding-olm" not found
olm-operator                                    olm          Deployment                  deployments.apps "olm-operator" not found
catalog-operator                                olm          Deployment                  deployments.apps "catalog-operator" not found
olm-operator-serviceaccount                     olm          ServiceAccount              serviceaccounts "olm-operator-serviceaccount" not found
operators                                                    Namespace                   namespaces "operators" not found
global-operators                                operators    OperatorGroup               operatorgroups.operators.coreos.com "global-operators" not found
olm-operators                                   olm          OperatorGroup               operatorgroups.operators.coreos.com "olm-operators" not found
packageserver                                   olm          ClusterServiceVersion       clusterserviceversions.operators.coreos.com "packageserver" not found
operatorhubio-catalog                           olm          CatalogSource               catalogsources.operators.coreos.com "operatorhubio-catalog" not found


Fetch the CRDs for version "0.16.1" successfully. 
BTW, check the git repo https://github.com/operator-framework/operator-lifecycle-manager. The CRD yaml file has been uploaded correctly.
Verify the bug on OCP 4.6.

Comment 7 errata-xmlrpc 2020-10-27 16:33:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.