Bug 187224 - unowned directory /var/games
unowned directory /var/games
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ularn (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Wart
Fedora Extras Quality Assurance
:
Depends On: 165425
Blocks: FE6Target
  Show dependency treegraph
 
Reported: 2006-03-29 07:10 EST by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-05 16:56:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2006-03-29 07:10:26 EST
Hi Michael,

While packaging shippy I noticed that there is no such thing as /var/games on
recent Fedora versions, try doing a rpm -qf /var/games it is unowned, doing a
rpm -ql filesystem shows /var/lib/games which is used by atleast gnome-games.

So I believe that we (the games SIG) should also use /var/lib/games and not
/var/games .

This needs updating in the wiki too.
Comment 1 Wart 2006-03-30 12:11:07 EST
According to the FHS, /var/games is the preferred place for variable game data.
 It's explicitly split out of /var/lib to allow for local control of backup
strategies, permissions, etc.

However, as you note, /var/games is not owned by any package.  /var/lib/games is
owned by the filesystem package.  IMO, Fedora is violating the FHS by using
/var/lib/games instead of /var/games, and we should file a bug against the
filesystem package to use /var/games instead of /var/lib/games.
Comment 2 Hans de Goede 2006-03-31 02:53:44 EST
Done, see bug 165425
Comment 3 Wart 2006-07-05 16:56:03 EDT
Closing as NOTABUG, since this is a filesystem bug fixed implicitly with bug 165425.

Note You need to log in before you can comment on or make changes to this bug.