Bug 1872324 - pyanaconda.payload.errors.PayloadError: Payload error - DNF installation has ended up abruptly: Transaction test error:
Summary: pyanaconda.payload.errors.PayloadError: Payload error - DNF installation has ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: f33-backgrounds
Version: 33
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Luya Tshimbalanga
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:914da96333648faebbca524e332...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-25 13:54 UTC by Adriano
Modified: 2020-10-06 14:05 UTC (History)
10 users (show)

Fixed In Version: f33-backgrounds-33.0.6-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-06 14:05:23 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (2.87 MB, text/plain)
2020-08-25 13:55 UTC, Adriano
no flags Details
File: anaconda.log (36.64 KB, text/plain)
2020-08-25 13:55 UTC, Adriano
no flags Details
File: dbus.log (2.63 KB, text/plain)
2020-08-25 13:55 UTC, Adriano
no flags Details
File: dnf.librepo.log (263.53 KB, text/plain)
2020-08-25 13:55 UTC, Adriano
no flags Details
File: environ (637 bytes, text/plain)
2020-08-25 13:55 UTC, Adriano
no flags Details
File: lorax-packages.log (24.64 KB, text/plain)
2020-08-25 13:55 UTC, Adriano
no flags Details
File: lsblk_output (3.44 KB, text/plain)
2020-08-25 13:55 UTC, Adriano
no flags Details
File: nmcli_dev_list (2.25 KB, text/plain)
2020-08-25 13:55 UTC, Adriano
no flags Details
File: os_info (730 bytes, text/plain)
2020-08-25 13:55 UTC, Adriano
no flags Details
File: program.log (15.11 KB, text/plain)
2020-08-25 13:55 UTC, Adriano
no flags Details
File: storage.log (396.96 KB, text/plain)
2020-08-25 13:55 UTC, Adriano
no flags Details
File: syslog (1.09 MB, text/plain)
2020-08-25 13:55 UTC, Adriano
no flags Details
File: packaging.log (33.10 KB, text/plain)
2020-08-25 13:55 UTC, Adriano
no flags Details

Description Adriano 2020-08-25 13:54:52 UTC
Description of problem:
While installing from Netinstall trying MATE Desktop

Version-Release number of selected component:
anaconda-33.25.2

The following was filed automatically by anaconda:
anaconda 33.25.2 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.9/site-packages/pyanaconda/payload/dnf/payload.py", line 1407, in install
    raise PayloadError(msg)
  File "/usr/lib64/python3.9/site-packages/pyanaconda/installation_tasks.py", line 456, in run_task
    self._task(*self._task_args, **self._task_kwargs)
  File "/usr/lib64/python3.9/site-packages/pyanaconda/installation_tasks.py", line 490, in start
    self.run_task()
  File "/usr/lib64/python3.9/site-packages/pyanaconda/installation_tasks.py", line 311, in start
    item.start()
  File "/usr/lib64/python3.9/site-packages/pyanaconda/installation_tasks.py", line 311, in start
    item.start()
  File "/usr/lib64/python3.9/site-packages/pyanaconda/installation_tasks.py", line 311, in start
    item.start()
  File "/usr/lib64/python3.9/site-packages/pyanaconda/installation.py", line 395, in run_installation
    queue.start()
  File "/usr/lib64/python3.9/threading.py", line 888, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.9/site-packages/pyanaconda/threading.py", line 280, in run
    threading.Thread.run(self)
pyanaconda.payload.errors.PayloadError: Payload error - DNF installation has ended up abruptly: Transaction test error:
  file /usr/share/backgrounds/mate/default.xml conflicts between attempted installs of f33-backgrounds-mate-33.0.2-1.fc33.noarch and f32-backgrounds-mate-32.2.2-2.fc33.noarch
Traceback (most recent call last):
  File "/usr/lib64/python3.9/site-packages/pyanaconda/payload/dnf/utils.py", line 130, in do_transaction
    base.do_transaction(display=display)
  File "/usr/lib/python3.9/site-packages/dnf/base.py", line 857, in do_transaction
    raise dnf.exceptions.Error(errstring)
dnf.exceptions.Error: Transaction test error:
  file /usr/share/backgrounds/mate/default.xml conflicts between attempted installs of f33-backgrounds-mate-33.0.2-1.fc33.noarch and f32-backgrounds-mate-32.2.2-2.fc33.noarch



Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-E-dvd-x86_64-33 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
hawkey.log:     INFO ago-25 13:42:21 === Started libdnf-0.48.0 ===
kernel:         5.8.3-300.fc33.x86_64
product:        Fedora
release:        Fedora release 33 (Thirty Three)
release_type:   pre-release
type:           anaconda
version:        33

Comment 1 Adriano 2020-08-25 13:55:00 UTC
Created attachment 1712542 [details]
File: anaconda-tb

Comment 2 Adriano 2020-08-25 13:55:02 UTC
Created attachment 1712543 [details]
File: anaconda.log

Comment 3 Adriano 2020-08-25 13:55:04 UTC
Created attachment 1712544 [details]
File: dbus.log

Comment 4 Adriano 2020-08-25 13:55:07 UTC
Created attachment 1712545 [details]
File: dnf.librepo.log

Comment 5 Adriano 2020-08-25 13:55:09 UTC
Created attachment 1712546 [details]
File: environ

Comment 6 Adriano 2020-08-25 13:55:10 UTC
Created attachment 1712547 [details]
File: lorax-packages.log

Comment 7 Adriano 2020-08-25 13:55:12 UTC
Created attachment 1712548 [details]
File: lsblk_output

Comment 8 Adriano 2020-08-25 13:55:13 UTC
Created attachment 1712549 [details]
File: nmcli_dev_list

Comment 9 Adriano 2020-08-25 13:55:15 UTC
Created attachment 1712550 [details]
File: os_info

Comment 10 Adriano 2020-08-25 13:55:17 UTC
Created attachment 1712551 [details]
File: program.log

Comment 11 Adriano 2020-08-25 13:55:20 UTC
Created attachment 1712552 [details]
File: storage.log

Comment 12 Adriano 2020-08-25 13:55:24 UTC
Created attachment 1712553 [details]
File: syslog

Comment 13 Adriano 2020-08-25 13:55:26 UTC
Created attachment 1712554 [details]
File: packaging.log

Comment 14 Vladimír Slávik 2020-09-01 17:15:40 UTC
Thank you for the report! The error message says this is caused by a conflict between the f32 and f33 mate backgrounds packages. Reassigning.

Comment 15 Wolfgang Ulbrich 2020-09-16 11:44:42 UTC
The f33-backgrounds-mate-33.0.2-1.fc33.noarch was pulled in by Mate environment group of comps.
The f32-backgrounds-mate-32.2.2-2.fc33.noarch was pulled in by mate-desktop-1.24.1-1.fc33 package.
I updated mate-desktop package to fix this mismatch at Aug 25 2020 13:12:00 shortly before beta freeze, but report is from 2020-08-25 13:54:52.
https://src.fedoraproject.org/rpms/mate-desktop/c/f41df67b39a438faf9db00637fa8fe23235801b1?branch=master
So this problem was fixed when mate-desktop-1.24.1-2.fc33 reached stable branch before beta freeze ;)

Comment 16 Vladimír Slávik 2020-09-16 13:01:21 UTC
This seems to be fixed - trying with a f33 compose with anaconda-33.25.2-3 built two days ago or earlier. Close as needed...

Comment 17 Fedora Update System 2020-09-17 01:04:26 UTC
FEDORA-2020-9e58541c44 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-9e58541c44

Comment 18 Fedora Update System 2020-09-17 17:55:08 UTC
FEDORA-2020-9e58541c44 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-9e58541c44`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-9e58541c44

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2020-09-23 04:50:15 UTC
FEDORA-2020-9e58541c44 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-9e58541c44

Comment 20 Fedora Update System 2020-10-06 01:41:52 UTC
FEDORA-2020-0c0496fb3e has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-0c0496fb3e

Comment 21 Fedora Update System 2020-10-06 14:05:23 UTC
FEDORA-2020-0c0496fb3e has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.