Bug 187238 - system-config-display causes freezing
system-config-display causes freezing
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-29 09:24 EST by Joel
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-03 14:06:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg-log (91.36 KB, text/plain)
2006-03-31 03:24 EST, jon
no flags Details

  None (edit)
Description Joel 2006-03-29 09:24:25 EST
Description of problem:
Fedora never correctly assigned monitor.  When I try to enter
system-config-display the system will become totally unresponsive (locks up
good).  I have this same issue with the use of Kudzu and Firstboot.


Version-Release number of selected component (if applicable):
The one that installs from FC5 (guessing test 1 b/c i just d/led it and installed)

How reproducible:
Just clicking on system-config-display or trying to run it via terminal will
result in lock-up. 

Steps to Reproduce:
1. Run system-config-display or kudzu how ever you want to
2. Sit back and watch it lock-up instantly
3. Pound desk with fist
  
Actual results:
Lock-up on every case

Expected results:
Lock-up on every case but the first (but that locked up too)

Additional info:
I have a radeon x850xt, it got that just fine and set everything up for me
-Awesome improvement over FC4!- but it wont detect my Monitor which is a
Viewsonic A90F+
Comment 1 jon 2006-03-31 03:19:03 EST
Me too here.
System-config locks up the pc hard. I am not able to use the freshly installed
FedoraCore 5, because firstboot insists on System-config and never succeds
because the lockup.
My System Specs:

MS-6702 (Via KT800pro) Athlon64 3000+ Radeon X800GTO (1002:4a49).

If you need more information feel free to ask.
Comment 2 jon 2006-03-31 03:24:34 EST
Created attachment 127108 [details]
Xorg-log

I started system-config-display in single-user mode manually to setup the vesa
driver, as i thought radeon driver might be the suspect, however after letting
it setup my xorg.conf it still locks-up the system, so heres now the xorg-log.

cheers Jon
Comment 3 Tethys 2006-05-09 12:54:09 EDT
Yep, me too. The system deadlocks as soon as I run system-config-display, to
the extent that even Magic SysRq doesn't work. It worked fine under FC4, but
now that I've upgraded to FC5, it deadlocks.

mrburns:~# cat /etc/redhat-release 
Fedora Core release 5 (Bordeaux)
mrburns:~# uname -p
x86_64
mrburns:~# rpm -q xorg-x11-{server-Xorg,drivers,drv-ati} system-config-display
xorg-x11-server-Xorg-1.0.1-9.fc5.1.1
xorg-x11-drivers-7.0-2
xorg-x11-drv-ati-6.5.7.3-4
system-config-display-1.0.37-2
mrburns:~# lspci | grep ATI
02:00.0 VGA compatible controller: ATI Technologies Inc Unknown device 5d4f
02:00.1 Display controller: ATI Technologies Inc Unknown device 5d6f

The video card is an ATI X800 GTO. I have two heads -- an Iiyama MA203DT and
a Sony SDM-S205FB.

Hardware should be changed to "All" as I'm using an x86_64 machine, not i686.
Comment 4 Adam Jackson 2007-01-30 09:45:27 EST
s-c-d should no longer be calling out to ddcprobe, so this should no longer
happen as of FC6.  Please test, and reopen if this bug is still present for you.

Thanks for the report!
Comment 5 Adam Jackson 2007-04-03 14:06:37 EDT
NEEDINFO timeout, resolving as INSUFFICIENT_DATA.

Note You need to log in before you can comment on or make changes to this bug.