Bug 1872417 - Crash in discovery mode when no performance profile is applied
Summary: Crash in discovery mode when no performance profile is applied
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: CNF Platform Validation
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Federico Paolinelli
QA Contact: Nikita
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-25 16:37 UTC by Federico Paolinelli
Modified: 2020-10-27 16:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:33:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift-kni performance-addon-operators pull 330 0 None closed Bug 1872417: E2e tests - do not panic in discovery mode with no profile installed. 2020-10-06 08:17:11 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:33:23 UTC

Description Federico Paolinelli 2020-08-25 16:37:54 UTC
Description of problem:
When running cnf tests in discovery mode but no performance profile is found, the test suite crashes instead of handling it gracefully.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run cnf tests with discovery mode enabled but no perf profile applied.

Actual results:
Panic

Expected results:
Skipping the tests with a meaningful reason

Additional info:

Comment 7 errata-xmlrpc 2020-10-27 16:33:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.