Bug 1872429 - login screen returns after live-iso user log (maybe LTO issue)
Summary: login screen returns after live-iso user log (maybe LTO issue)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lxsession
Version: 33
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F33BetaFreezeException 1789115
TreeView+ depends on / blocked
 
Reported: 2020-08-25 17:13 UTC by Adriano
Modified: 2020-10-23 22:12 UTC (History)
6 users (show)

Fixed In Version: lxsession-0.5.5-4.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-23 22:12:27 UTC
Type: Bug


Attachments (Terms of Use)

Description Adriano 2020-08-25 17:13:25 UTC
Description of problem:

After loading the LXDE 33 live-iso log screen, when you click on the LiveSystemUser account and the password is provided, the login screen returns again after Playmonth repeatedly.


Version-Release number of selected component (if applicable):

Fedora LXDE 33 Live-ISO

How reproducible:

Only load the LXDE 33 Live-ISO and try to log with LiveSystemUser

Steps to Reproduce:

1. Download LXDE 33 Live-ISO from https://kojipkgs.fedoraproject.org/compose/branched/Fedora-33-20200822.n.0/compose/Spins/x86_64/iso/Fedora-LXDE-Live-x86_64-33-20200822.n.0.iso

2. Record the Live-ISO to a USB-Stick using DD ou GNOME-DISK
3. Load the USB-Live-Stick and try to login with LiveSystemUser

Actual results:

The System can't load Desktop after login.

Expected results:

Load Desktop after Login. 

Additional info:

The same happens when LXDE 33 is installed from Minimal, Everything installation.

Comment 1 Mamoru TASAKA 2020-08-27 03:44:01 UTC
Would you check if the following scratch build cures this issue?

https://koji.fedoraproject.org/koji/taskinfo?taskID=50218054

Comment 2 Mamoru TASAKA 2020-08-27 13:06:16 UTC
Well, still waiting for confirmation from the reporter, as far as I checked this issue, disabling lto for lxsession seems to work well.

I will push this for F33 beta for now. I may find more proper solution later, but for now it should be okay.

Comment 3 Fedora Update System 2020-08-27 13:19:03 UTC
FEDORA-2020-d335b7b4ef has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-d335b7b4ef

Comment 4 Fedora Blocker Bugs Application 2020-08-27 13:19:53 UTC
Proposed as a Freeze Exception for 33-beta by Fedora user mtasaka using the blocker tracking app because:

 LXDE live spin is not functional. After login, LXDE session just closes and goes back to login screen.

Comment 5 Mamoru TASAKA 2020-08-27 13:21:22 UTC
Law, would you give some advice for me about this issue?

Comment 6 Jeff Law 2020-08-27 17:27:39 UTC
Thanks.  Again, opting lxsession out LTO seems like the most prudent solution so as to not impact F33.  I note that my .spec file scanner picked up the change this morning, so it's in my queue of things needing deeper investigation.

THe toughest part here will probably be finding a way to test this quickly/easily without needing to "burn" a memory stick for every test, or even start up a new vm/container every time.    But this is also one of the most concerning LTO issues in the queue as there's either a codegen issue in GCC or something undefined in the lxsession codebase that is being exposed by LTO.

So closing as the immediate F33 issue is worked around and lxsession is showing up in my .spec file scanner as needing a deeper investigation.

Thanks!

Comment 7 Fedora Update System 2020-08-27 19:05:14 UTC
FEDORA-2020-d335b7b4ef has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-d335b7b4ef`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-d335b7b4ef

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 František Zatloukal 2020-08-31 12:13:03 UTC
+3 votes for FE, setting as AcceptedFE.

https://pagure.io/fedora-qa/blocker-review/issue/46

Comment 9 Adriano 2020-08-31 14:37:28 UTC
(In reply to Mamoru TASAKA from comment #2)
> Well, still waiting for confirmation from the reporter, as far as I checked
> this issue, disabling lto for lxsession seems to work well.
> 
> I will push this for F33 beta for now. I may find more proper solution
> later, but for now it should be okay.

Hello Dear TASAKA...

Sorry for delay your requests...

I tested the newest ISO of Fedora LXDE dated 08/31-2020 and the problem reported initially still persists.

I would like to add that I tested on several different machines and in different bios-firmware modes, including UEFI and CSM / Legacy and the result led to the same problems of returning the Login screen.

Even without the LTO problem, the problem persists.

Only in pure Openbox mode is the system able to log in normally.

Comment 10 Mamoru TASAKA 2020-09-01 00:05:41 UTC
Well, Fedora-LXDE-Live-33-20200831.n.0 does not have lxsession-0.5.5-3.fc33 yet so if you just use Fedora-LXDE-Live-33-20200831.n.03 you will surely see this issue.


Would you try the following?

* Use Fedora-LXDE-Live-33-20200831.n.0 Live image, once trying graphical boot, then login fails and return to login screen
* Change to CUI by ctrl-alt-F3, for example.
* login as liveuser (liveuser has no password)
* Download rpms from https://koji.fedoraproject.org/koji/buildinfo?buildID=1601782
* Install them by $ sudo rpm -Fvh *rpm
* Go back to GUI (by ctrl-alt-F1),
* and try graphical login again

?

Comment 11 Adriano 2020-09-01 14:15:46 UTC
(In reply to Mamoru TASAKA from comment #10)
> Well, Fedora-LXDE-Live-33-20200831.n.0 does not have lxsession-0.5.5-3.fc33
> yet so if you just use Fedora-LXDE-Live-33-20200831.n.03 you will surely see
> this issue.
> 
> 
> Would you try the following?
> 
> * Use Fedora-LXDE-Live-33-20200831.n.0 Live image, once trying graphical
> boot, then login fails and return to login screen
> * Change to CUI by ctrl-alt-F3, for example.
> * login as liveuser (liveuser has no password)
> * Download rpms from
> https://koji.fedoraproject.org/koji/buildinfo?buildID=1601782
> * Install them by $ sudo rpm -Fvh *rpm
> * Go back to GUI (by ctrl-alt-F1),
> * and try graphical login again
> 
> ?

Dear Mamoru TASAKA...

I did all the recommended procedures just using pure Openbox instead of CUI (CTRL + ALT + FunctionKey) and it worked perfectly.
From now on I will try to install LXDE 33 and see if other problems happen.
I thank you in advance for your precious time dedicated to this problem.

Comment 12 Mamoru TASAKA 2020-09-01 14:33:16 UTC
Okay, thank you for confirming. I think lxsession-0.5.5-3.fc33 will finally included in LXDE Fedora 33 beta spin.

Comment 13 Adam Williamson 2020-09-03 22:18:38 UTC
Mamoru: only if the update is submitted for stable, either by getting enough karma or waiting long enough. You should be able to submit it manually tomorrow or the day after, I think. Thanks!

Comment 14 Mamoru TASAKA 2020-09-07 10:50:02 UTC
Hello, Adam: Will the updated lxsession rpm be included in next compose? (I've requested lxsession update to stable.)

Comment 15 František Zatloukal 2020-09-07 11:04:08 UTC
(In reply to Mamoru TASAKA from comment #14)
> Hello, Adam: Will the updated lxsession rpm be included in next compose?
> (I've requested lxsession update to stable.)

Hi,

since we're now in freeze, push requests to stable must be made manually.

I've requested some push requests, including one for this bug: https://pagure.io/releng/issue/9725#comment-676218 , it should be in a compose after that request is fulfilled, probably in tomorrow's compose.

Comment 16 Mamoru TASAKA 2020-09-07 11:51:34 UTC
(In reply to František Zatloukal from comment #15)
> (In reply to Mamoru TASAKA from comment #14)
> > Hello, Adam: Will the updated lxsession rpm be included in next compose?
> > (I've requested lxsession update to stable.)
> 
> Hi,
> 
> since we're now in freeze, push requests to stable must be made manually.
> 
> I've requested some push requests, including one for this bug:
> https://pagure.io/releng/issue/9725#comment-676218 , it should be in a
> compose after that request is fulfilled, probably in tomorrow's compose.

I see...  Thank you.

Comment 17 Fedora Update System 2020-09-08 17:04:13 UTC
FEDORA-2020-d335b7b4ef has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 18 Mamoru TASAKA 2020-09-09 13:04:21 UTC
Okay, Fedora-LXDE-Live-33-20200909.n.0 seems fine. Thank you, everyone.

Comment 19 Mamoru TASAKA 2020-10-12 14:29:28 UTC
So after debugging, LTO issue was because of some mistake in the code I wrote... Ah.

https://src.fedoraproject.org/rpms/lxsession/blob/f3e8a76425c15539fb9be4bbb2e6f3dd54a30537/f/lxsession-0.5.2-git9f8d6133-reload.patch#_30

So `gboolean xdpy_init()` does not "return TRUE;" at the last, then LTO seems to be thinking (from gdb) in xevent_init(), xdpy_init() will always return FALSE.

Comment 20 Mamoru TASAKA 2020-10-12 14:33:49 UTC
As lxsession-0.5.5-3.fc33 is on F-33 buildtree already, no furture freeze-exception request is needed.

Comment 21 Fedora Update System 2020-10-12 14:34:20 UTC
FEDORA-2020-fa1ca4378a has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-fa1ca4378a

Comment 22 Jeff Law 2020-10-12 14:43:18 UTC
So at this point this is not an LTO issue.  Can we re-enable LTO in rawhide for lxsession?

Comment 23 Mamoru TASAKA 2020-10-12 14:47:37 UTC
I've enabled LTO again on lxsession-0.5.5-4.fc3{3,4} .

Comment 24 Jeff Law 2020-10-12 14:56:30 UTC
Thanks.  The other thing that's odd here is I would have expected the compiler to warn for the code you referenced in c#19:

+gboolean xdpy_init()
+{
+	dpy = XOpenDisplay( g_getenv("DISPLAY") );
+	if( ! dpy )
+		return FALSE;
+}


In particular I would have expected -Wreturn-type to have flagged this function as returning without a value.  It should be enabled as part of -Wall IIRC.

Comment 25 Mamoru TASAKA 2020-10-12 15:08:34 UTC
Yes, but during debugging, actually I've noticed (surprisingly)

https://github.com/lxde/lxsession/blob/master/Makefile.am#L437

... there is "-w", actually... So in fact all warnings are suppressed (I didn't notice this).

In lxsession.spec, I've removed this "-w" to show warnings.

Comment 26 Fedora Update System 2020-10-12 22:46:07 UTC
FEDORA-2020-fa1ca4378a has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-fa1ca4378a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-fa1ca4378a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 27 Fedora Update System 2020-10-23 22:12:27 UTC
FEDORA-2020-fa1ca4378a has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.