Bug 1872599 - [LSO] e2e tests for LocalVolumeDiscovery fails randomly
Summary: [LSO] e2e tests for LocalVolumeDiscovery fails randomly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Santosh Pillai
QA Contact: Chao Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-26 07:40 UTC by Santosh Pillai
Modified: 2020-10-27 16:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:34:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift local-storage-operator pull 144 0 None closed Bug 1872599: fix e2e tests for localvolumediscovery 2020-10-01 08:11:50 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:34:33 UTC

Description Santosh Pillai 2020-08-26 07:40:28 UTC
Description of problem:
ete tests for localvolumediscovery fails randomly

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start et2 tests - `sh hack/test-e2e.sh`

Actual results:
LocalVolumeDiscovery e2e tests fails randomly for fetching the LocalVolumeDiscoveryResult CR. 


Expected results:
tests should be successful 

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:

e2e logs:

 localvolume_test.go:331: Waiting for full availability of diskmaker-discovery daemonset (0/1)
 localvolume_test.go:331: Waiting for full availability of diskmaker-discovery daemonset (0/1)
 localvolume_test.go:337: Daemonset available (1/1)
 localvolumediscovery_test.go:83: error verifying localvolumediscoveryresult. localvolumediscoveryresults.local.storage.openshift.io "discovery-result-ip-10-0-132-93.ec2.internal" not found

Comment 3 Chao Yang 2020-09-25 08:55:13 UTC
=== RUN   TestLocalStorage/LocalVolumeDiscovery
    localvolume_test.go:358: Node ip-10-0-143-32.us-east-2.compute.internal updated successfully
    localvolume_test.go:323: Waiting for availability of diskmaker-discovery daemonset
    localvolume_test.go:323: Waiting for availability of diskmaker-discovery daemonset
    localvolume_test.go:331: Waiting for full availability of diskmaker-discovery daemonset (0/1)
    localvolume_test.go:331: Waiting for full availability of diskmaker-discovery daemonset (0/1)
    localvolume_test.go:337: Daemonset available (1/1)
    localvolumediscovery_test.go:213: LocalVolumeDiscoveryResult "discovery-result-ip-10-0-143-32.us-east-2.compute.internal" not found.

Comment 5 errata-xmlrpc 2020-10-27 16:34:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.