Bug 1872646 - [oVirt] Installer doesn't remove tmp VM disk
Summary: [oVirt] Installer doesn't remove tmp VM disk
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.6.0
Assignee: Gal Zaidman
QA Contact: Guilherme Santos
URL:
Whiteboard:
Depends On: 1873022
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-26 09:36 UTC by Gal Zaidman
Modified: 2020-10-27 16:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:34:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 4129 0 None closed BUG 1872646: oVirt, remove tmp VM disk on destroy 2020-10-20 11:11:59 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:34:33 UTC

Description Gal Zaidman 2020-08-26 09:36:00 UTC
Description of problem:

When we run the installer the first thing that happens is that a tmp VM is created (which turns into a template). That VM is created with terraform by the terraform provider. 
The logic we currently have for the terraform provider is that a VM disk is not removed by default

https://github.com/oVirt/terraform-provider-ovirt/blob/master/ovirt/resource_ovirt_vm.go#L773


Version-Release number of the following components:

How reproducible:
Start an installation without overriding the tempalte.
when the installation finishes the tmpvm is removed but the disk lives on.

Comment 1 David Eads 2020-08-26 18:53:54 UTC
This is still causing a very high percentage of ovirt tests to fail, so I'm increasing the severity to match.  We use these tests to determine if our product is ready to ship so we need to be able to run them reliably.

Comment 4 Jan Zmeskal 2020-09-29 12:18:03 UTC
Verified with: 4.6.0-0.nightly-2020-09-28-212756

The temporary VM is removed after the bootstrap phase finished and the disk is removed as well (checked in Storage -> Disks in webadmin).

Comment 6 errata-xmlrpc 2020-10-27 16:34:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.