Bug 1872745 - lsmcli fails with "PLUGIN_BUG(2): Got unexpected error 'NoneType' object has no attribute '__getitem__', please try to upgrade ssacli tool"
Summary: lsmcli fails with "PLUGIN_BUG(2): Got unexpected error 'NoneType' object has ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libstoragemgmt
Version: 7.8
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Tony Asleson
QA Contact: ChanghuiZhong
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-26 14:33 UTC by John Pittman
Modified: 2021-09-03 14:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-16 13:56:31 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description John Pittman 2020-08-26 14:33:10 UTC
Description of problem:

[root@hostname ~]# lsmcli -u hpsa:// ld
PLUGIN_BUG(2): Got unexpected error 'NoneType' object has no attribute '__getitem__', please try to upgrade ssacli tool

Version-Release number of selected component (if applicable):

RHEL 7.8 using ESKM encrypted storage

How reproducible:

Every time

Steps to Reproduce (from end customer):

To recreate the problematic text that we're excluding in the plugin just run:

   ssacli ctrl all show config detail

And on ESKM encrypted controllers you'll see:

Encryption is enabled on this controller. Data stored on physical drives
exposed to the OS and not configured in an Array are not encrypted.

If you don't exclude these the plugin fails for certain options.

Additional info:

Workaround (from end customer) from /usr/lib/python2.7/site-packages/lsm/plugin/hpsa/hpsa.py

change:

            elif output_lines[i].startswith('Note'):
                # Discard
                pass
            else:
                sanitized.append(output_lines[i])

to

            elif output_lines[i].startswith('Note') or output_lines[i].startswith('Encryption is enabled') or output_lines[i].startswith('exposed to the OS'):
                # Discard
                pass
            else:
                sanitized.append(output_lines[i])

Comment 6 Chris Williams 2020-11-11 21:55:56 UTC
Red Hat Enterprise Linux 7 shipped it's final minor release on September 29th, 2020. 7.9 was the last minor releases scheduled for RHEL 7.
From intial triage it does not appear the remaining Bugzillas meet the inclusion criteria for Maintenance Phase 2 and will now be closed. 

From the RHEL life cycle page:
https://access.redhat.com/support/policy/updates/errata#Maintenance_Support_2_Phase
"During Maintenance Support 2 Phase for Red Hat Enterprise Linux version 7,Red Hat defined Critical and Important impact Security Advisories (RHSAs) and selected (at Red Hat discretion) Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available."

If this BZ was closed in error and meets the above criteria please re-open it flag for 7.9.z, provide suitable business and technical justifications, and follow the process for Accelerated Fixes:
https://source.redhat.com/groups/public/pnt-cxno/pnt_customer_experience_and_operations_wiki/support_delivery_accelerated_fix_release_handbook  

Feature Requests can re-opened and moved to RHEL 8 if the desired functionality is not already present in the product. 

Please reach out to the applicable Product Experience Engineer[0] if you have any questions or concerns.  

[0] https://bugzilla.redhat.com/page.cgi?id=agile_component_mapping.html&product=Red+Hat+Enterprise+Linux+7

Comment 7 Chris Williams 2020-11-11 23:18:12 UTC
Apologies for the inadvertent closure.

Comment 12 ChanghuiZhong 2021-02-07 03:32:19 UTC
Reproduced this issue with ssacli-3.30-14 + libstoragemgmt-1.7.3-3

[root@storageqe-65 ~]# lsmcli -u hpsa:// ld
PLUGIN_BUG(2): Got unexpected error 'NoneType' object has no attribute '__getitem__', please try to upgrade ssacli tool 
[root@storageqe-65 ~]# 
[root@storageqe-65 ~]# rpm -qa | grep ssacli
ssacli-3.30-14.0.x86_64
[root@storageqe-65 ~]# rpm -qa | grep libstoragemgmt
libstoragemgmt-1.7.3-3.el7.x86_64
libstoragemgmt-python-1.7.3-3.el7.noarch
libstoragemgmt-python-clibs-1.7.3-3.el7.x86_64
libstoragemgmt-hpsa-plugin-1.7.3-3.el7.noarch
[root@storageqe-65 ~]# 


confirmed that after upgrad libstoragemgmt to 1.8.1-2.el7_9, this issue does not appear again,
the command "lsmcli -u hpsa:// ld" is successfully executed.

[root@storageqe-65 ~]# rpm -qa | grep libstoragemgmt
libstoragemgmt-1.8.1-2.el7_9.x86_64
libstoragemgmt-python-1.8.1-2.el7_9.noarch
libstoragemgmt-python-clibs-1.8.1-2.el7_9.x86_64
libstoragemgmt-hpsa-plugin-1.8.1-2.el7_9.noarch
[root@storageqe-65 ~]# 
[root@storageqe-65 ~]# rpm -qa | grep ssacli
ssacli-3.30-14.0.x86_64
[root@storageqe-65 ~]# 
[root@storageqe-65 ~]# lsmcli -u hpsa:// ld
ID       | Name                         | Type | Size         | Status | System ID      | SCSI VPD 0x83 | Disk Paths | Revolutions Per Minute | Link Type
---------------------------------------------------------------------------------------------------------------------------------------------------------
WFJ0PEFF | HP      EG000600JWJNP 1I:3:1 | SAS  | 644245094400 | OK     | PEYHC0DRHBG034 |               |            | 10500                  | SAS      
[root@storageqe-65 ~]# 


Move to verified

Comment 21 errata-xmlrpc 2021-03-16 13:56:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (libstoragemgmt bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0859


Note You need to log in before you can comment on or make changes to this bug.