Bug 187285 - add pci ids to atiixp.c
add pci ids to atiixp.c
Status: CLOSED DUPLICATE of bug 173919
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-29 14:38 EST by Jason Baron
Modified: 2013-03-06 00:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-29 14:43:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pci ids (1.45 KB, patch)
2006-03-29 14:38 EST, Jason Baron
no flags Details | Diff

  None (edit)
Description Jason Baron 2006-03-29 14:38:26 EST
Description of problem:

David Bein writes:

Hello Jason,

 I just upgraded to -34.EL and all seems fine, but I was hoping
that you folks would already have a patch which is needed
for various AMD64 motherboards with the ATI IXP controllers.
These are common on HP/Compaq ASUS/MSI motherboards these
days in addition to any other number of vendors [Acer] using the
ATI chipset in various laptops.

 Briefly, this patch recognizes ATIIXP 300 and 400 controllers
in addition to the 200 controller. Without this patch, the speed
of disks connected to a motherboard with these controllers
is on the order of 1mb per second. With the patch, the disks
behave as expected.

  I do not know the proper way to submit a patch or bug-report,
so perhaps you could tell me. I would like to be able to actually do
installs on these machines in both 32-bit and 64-bit builds, but between
this problem and various ACPI issues, it ends up being a real pain in the
neck. I ended up rolling my own rescue CD just to fold in this patch.
But it would be better to avoid the hassle of doing that in the future.

 Attached are 2 patches, one for include/linux/pci_ids.h and
the other for drivers/ide/pci/atiixp.c. If you need these in a
different flavor of diff, please let me know which form is
the most helpful.

 Thanks very much ...

--David

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jason Baron 2006-03-29 14:38:26 EST
Created attachment 127013 [details]
pci ids
Comment 2 Jason Baron 2006-03-29 14:43:50 EST
oops. we already did this.

*** This bug has been marked as a duplicate of 173919 ***

Note You need to log in before you can comment on or make changes to this bug.