Bug 1872861 - [vsphere][upi] CSR kind does not exist when approving requests
Summary: [vsphere][upi] CSR kind does not exist when approving requests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.6.0
Assignee: aos-install
QA Contact: jima
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-26 18:36 UTC by Joseph Callen
Modified: 2021-07-29 08:22 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:34:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 4098 0 None closed Bug 1872861: Update cli container image for UPI 2021-02-19 09:14:00 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:34:51 UTC

Description Joseph Callen 2020-08-26 18:36:24 UTC
Description of problem:

vSphere UPI 4.6 fails to progress in CI with the following errors:


No resources found
no kind "CertificateSigningRequest" is registered for version "certificates.k8s.io/v1" in scheme "k8s.io/kubernetes/pkg/kubectl/scheme/scheme.go:28"
no kind "CertificateSigningRequest" is registered for version "certificates.k8s.io/v1" in scheme "k8s.io/kubernetes/pkg/kubectl/scheme/scheme.go:28"
no kind "CertificateSigningRequest" is registered for version "certificates.k8s.io/v1" in scheme "k8s.io/kubernetes/pkg/kubectl/scheme/scheme.go:28"
no kind "CertificateSigningRequest" is registered for version "certificates.k8s.io/v1" in scheme "k8s.io/kubernetes/pkg/kubectl/scheme/scheme.go:28"
no kind "CertificateSigningRequest" is registered for version "certificates.k8s.io/v1" in scheme "k8s.io/kubernetes/pkg/kubectl/scheme/scheme.go:28"
no kind "CertificateSigningRequest" is registered for version "certificates.k8s.io/v1" in scheme "k8s.io/kubernetes/pkg/kubectl/scheme/scheme.go:28"




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Stefan Schimanski 2020-08-26 18:43:04 UTC
We had the same issue in IPI installer. I bet this is the same issue:

  https://github.com/openshift/oc/pull/501
  https://github.com/openshift/installer/pull/3943

In other words: make sure it is an up-to-date oc.

Comment 5 jima 2020-09-01 06:44:17 UTC
On QE side, after changing the oc client version to latest one, approving CSR can be executed correctly.
And I also checked CI status on 4.6.0-0.nightly-2020-08-31-194600 where including the fix, it is successful on upi_on_vsphere.
So move the status to "VERIFIED"

Comment 7 errata-xmlrpc 2020-10-27 16:34:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.