Bug 1872881 - Clicking sink URI breaks the topology view
Summary: Clicking sink URI breaks the topology view
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-26 19:50 UTC by Jeff Phillips
Modified: 2020-10-27 16:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.6.0-0.nightly-2020-08-02-134243 Cluster ID: ab728797-a648-4efb-a556-e23c77a0cb7d Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.135 Safari/537.36
Last Closed: 2020-10-27 16:34:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
Bug fix validation (5.69 MB, image/gif)
2020-09-03 08:20 UTC, Abhishek K N
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6454 0 None closed Bug 1872881: Fix crash when selecting Sink URI node in topology 2020-09-02 13:20:22 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:34:51 UTC

Description Jeff Phillips 2020-08-26 19:50:38 UTC
Description of problem:

Clicking on sink URI breaks the topology view

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:

1. Go to Add page, click on event source card
2. select one of the event source and sink to URI
3. Go to topology page
4. Click on create sink uri node. Notice topology page breaks.

Actual results:

UI crashes

Expected results:

Side panel shows details for the sink uri.

Additional info:

Comment 3 Abhishek K N 2020-09-03 08:19:08 UTC
PSA. Topology page doesn't break on selecting sink URI & able to see side panel with resource details.

Verified build details:
  OpenShift Version: 4.6.0-0.nightly-2020-09-02-210353
  Kubernetes Version: v1.19.0-rc.2+b5dc585-dirty

Comment 4 Abhishek K N 2020-09-03 08:20:50 UTC
Created attachment 1713555 [details]
Bug fix validation

Comment 6 errata-xmlrpc 2020-10-27 16:34:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.